Bug 74473 - gnome-terminal segfautls on resize.
gnome-terminal segfautls on resize.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 18:50 EDT by David Woodhouse
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 16:35:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2002-09-24 18:50:37 EDT
Description of Problem:
Segfault.

Version-Release number of selected component (if applicable):
gnome-terminal-2.0.1-5
vte-0.8.19-1


How Reproducible:
occasional.

Steps to Reproduce:
1. Run 'less', showing a file large enough to fill a screen or two.
2. Click the corner of gnome-terminal to resize it.
3. Hold mouse button while dragging corner around.

Additional Information:

Starting program: /usr/bin/gnome-terminal 
[New Thread 8192 (LWP 28292)]

** ERROR **: NULL at 597(->21) delta 601, length 28, max 32 next 629 at 2376

aborting...

Program received signal SIGABRT, Aborted.
[Switching to Thread 8192 (LWP 28292)]
0x42028cc1 in kill () from /lib/i686/libc.so.6
(gdb) bt
#0  0x42028cc1 in kill () from /lib/i686/libc.so.6
#1  0x408f707d in raise () from /lib/i686/libpthread.so.0
#2  0x4202a019 in abort () from /lib/i686/libc.so.6
#3  0x4094a476 in g_logv () from /usr/lib/libglib-2.0.so.0
#4  0x4094a4b4 in g_log () from /usr/lib/libglib-2.0.so.0
#5  0x400435fe in vte_terminal_ensure_cursor () from /usr/lib/libvte.so.2
#6  0x40042a53 in vte_sequence_handler_ce () from /usr/lib/libvte.so.2
#7  0x4004878d in vte_terminal_handle_sequence () from /usr/lib/libvte.so.2
#8  0x4004958e in vte_terminal_process_incoming () from /usr/lib/libvte.so.2
#9  0x40944c83 in g_idle_dispatch () from /usr/lib/libglib-2.0.so.0
#10 0x40941f65 in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
#11 0x40942f98 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0x409432ad in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#13 0x40943a1f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0x4044539f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x08058256 in main ()
#16 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Alexander Larsson 2003-08-28 09:44:17 EDT
I can't reproduce this with vte 0.11.10-2 (from rawhide). Its highly probable
that this is fixed. Can you still see it on your machine?
Comment 2 Ray Strode [halfline] 2004-11-01 16:35:46 EST
Hi David,

If this happens again, please reopen.

Note You need to log in before you can comment on or make changes to this bug.