Bug 74513 - Psyche: info coredumps under ru_RU.UTF-8.
Psyche: info coredumps under ru_RU.UTF-8.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: texinfo (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 14:35 EDT by Aleksey Nogin
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 05:07:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-09-25 14:35:52 EDT
100% reproducible:

1) run 
env LC_ALL=ru_RU.UTF-8 info diff

2) Press "m".

Result:

Program received signal SIGSEGV, Segmentation fault.
0x420741ee in malloc_consolidate () from /lib/i686/libc.so.6
(gdb) bt
#0  0x420741ee in malloc_consolidate () from /lib/i686/libc.so.6
#1  0x42073d0c in _int_malloc () from /lib/i686/libc.so.6
#2  0x42073155 in malloc () from /lib/i686/libc.so.6
#3  0x080604f8 in strcpy ()
#4  0x0805f4a0 in strcpy ()
#5  0x0805efab in strcpy ()
#6  0x0804ac3b in strcpy ()
#7  0x0804b79f in strcpy ()
#8  0x0804b967 in strcpy ()
#9  0x08058736 in strcpy ()
#10 0x08058ba0 in strcpy ()
#11 0x0805c317 in strcpy ()
#12 0x080560ad in strcpy ()
#13 0x08055fcf in strcpy ()
#14 0x0804fd84 in strcpy ()
#15 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

info-4.2-5, glibc-2.2.93-5
Comment 1 Tim Waugh 2002-10-07 09:41:13 EDT
Does this still happen in Red Hat Linux 8.0? 
 
I can't reproduce the problem here, but I haven't tried a Russian install yet.
Comment 2 Aleksey Nogin 2003-01-06 20:40:42 EST
Works correctly in Phoebe.

Note You need to log in before you can comment on or make changes to this bug.