Bug 745217 - If Y-1 => Y-2, and X-1 reqs. Y-1 and X-2 also reqs. same ... yum does update of Y and assumes all is good
If Y-1 => Y-2, and X-1 reqs. Y-1 and X-2 also reqs. same ... yum does update ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 745206 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 13:17 EDT by Mads Kiilerich
Modified: 2014-01-21 18:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 12:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2011-10-11 13:17:42 EDT
On a f16 + testing system with
yum-3.4.3-5.fc16.noarch
rpm-4.9.1.2-1.fc16.i686

A plain "yum update" will fail up front with a real dependency issue, but when a package name is specified it won't notice the issue before it is "too late":

[root@user07 ~]# yum update -d9 evince
Not loading "blacklist" plugin, as it is disabled
Loading "langpacks" plugin
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Running "config" handler for "langpacks" plugin
Adding en_US to language list
Running "config" handler for "presto" plugin
Config time: 0.052
Yum Version: 3.4.3
COMMAND: yum update -d9 evince 
Installroot: /
Ext Commands:

   evince
Setting up Package Sacks
Running "postreposetup" handler for "langpacks" plugin
pkgsack time: 0.673
Reading Local RPMDB
rpmdb time: 0.001
Setting up Update Process
Building updates object
up:Obs Init time: 0.565
putting poppler-utils in simple update
putting evince-libs in simple update
putting perl-IO-Compress in simple update
putting poppler in simple update
putting evince-nautilus in simple update
putting evince in simple update
putting poppler-glib in simple update
putting tracker in simple update
up:simple updates time: 0.043
up:obs time: 0.032
up:condense time: 0.000
updates time: 1.532
Not Updating Package that is already updated: evince.i686 0:3.1.90-2.fc16
Not Updating Package that is already updated: evince.i686 0:3.1.90-2.fc16
Resolving Dependencies
--> Running transaction check
---> Package evince.i686 0:3.1.90-2.fc16 will be updated
Checking deps for evince.i686 0:3.1.90-2.fc16 - ud
evince-nautilus-3.1.90-2.fc16.i686 requires: evince = 3.1.90-2.fc16
--> Processing Dependency: evince = 3.1.90-2.fc16 for package: evince-nautilus-3.1.90-2.fc16.i686
Potential Provider: evince.i686 0:3.1.90-2.fc16
Mode is ud for provider of evince = 3.1.90-2.fc16: evince.i686 0:3.1.90-2.fc16
Mode for pkg providing evince = 3.1.90-2.fc16: ud
Trying to update evince-nautilus-3.1.90-2.fc16.i686 to resolve dep
---> Package evince.i686 0:3.2.0-2.fc16 will be an update
Checking deps for evince.i686 0:3.2.0-2.fc16 - u
looking for ('evince-libs', 'EQ', ('0', '3.2.0', '2.fc16')) as a requirement of evince.i686 0:3.2.0-2.fc16 - u
evince-3.2.0-2.fc16.i686 requires: evince-libs = 3.2.0-2.fc16
--> Processing Dependency: evince-libs = 3.2.0-2.fc16 for package: evince-3.2.0-2.fc16.i686
Searching pkgSack for dep: evince-libs
Not Updating Package that is already updated: evince-libs.i686 0:3.1.90-2.fc16
--> Running transaction check
---> Package evince-libs.i686 0:3.1.90-2.fc16 will be updated
Checking deps for evince-libs.i686 0:3.1.90-2.fc16 - ud
---> Package evince-libs.i686 0:3.2.0-2.fc16 will be an update
Checking deps for evince-libs.i686 0:3.2.0-2.fc16 - u
looking for ('libpoppler.so.18', None, (None, None, None)) as a requirement of evince-libs.i686 0:3.2.0-2.fc16 - u
evince-libs-3.2.0-2.fc16.i686 requires: libpoppler.so.18
--> Processing Dependency: libpoppler.so.18 for package: evince-libs-3.2.0-2.fc16.i686
Searching pkgSack for dep: libpoppler.so.18
Running compare_providers() for [<YumAvailablePackageSqlite : poppler-0.18.0-1.fc16.i686 (0xad53e0c)>, <YumAvailablePackageSqlite : poppler-0.18.0-1.fc16.i686 (0xad53c8c)>]
base package poppler is installed for poppler-0.18.0-1.fc16.i686
Best Order: [(<YumAvailablePackageSqlite : poppler-0.18.0-1.fc16.i686 (0xad53e0c)>, 1003)]
Not Updating Package that is already updated: poppler.i686 0:0.17.3-1.fc16
Running compare_providers() for [<YumAvailablePackageSqlite : poppler-0.18.0-1.fc16.i686 (0xad53e0c)>, <YumAvailablePackageSqlite : poppler-0.18.0-1.fc16.i686 (0xad53c8c)>]
base package poppler is installed for poppler-0.18.0-1.fc16.i686
Best Order: [(<YumAvailablePackageSqlite : poppler-0.18.0-1.fc16.i686 (0xad53e0c)>, 1003)]
Not Updating Package that is already updated: poppler.i686 0:0.17.3-1.fc16
Not Updating Package that is already updated: poppler.i686 0:0.17.3-1.fc16
---> Package evince-nautilus.i686 0:3.1.90-2.fc16 will be updated
Checking deps for evince-nautilus.i686 0:3.1.90-2.fc16 - ud
---> Package evince-nautilus.i686 0:3.2.0-2.fc16 will be an update
Checking deps for evince-nautilus.i686 0:3.2.0-2.fc16 - u
looking for ('evince', 'EQ', ('0', '3.2.0', '2.fc16')) as a requirement of evince-nautilus.i686 0:3.2.0-2.fc16 - u
looking for ('libm.so.6', None, (None, None, None)) as a requirement of evince-nautilus.i686 0:3.2.0-2.fc16 - u
--> Running transaction check
---> Package poppler.i686 0:0.17.3-1.fc16 will be updated
Checking deps for poppler.i686 0:0.17.3-1.fc16 - ud
poppler-glib-0.17.3-1.fc16.i686 requires: libpoppler.so.17
--> Processing Dependency: libpoppler.so.17 for package: poppler-glib-0.17.3-1.fc16.i686
Needed Require is not a package name. Looking up: libpoppler.so.17
Potential Provider: poppler.i686 0:0.17.3-1.fc16
Mode is ud for provider of libpoppler.so.17: poppler.i686 0:0.17.3-1.fc16
Mode for pkg providing libpoppler.so.17: ud
Trying to update poppler-glib-0.17.3-1.fc16.i686 to resolve dep
tracker-0.12.1-2.fc16.i686 requires: libpoppler.so.17
--> Processing Dependency: libpoppler.so.17 for package: tracker-0.12.1-2.fc16.i686
Needed Require has already been looked up, cheating
Potential Provider: poppler.i686 0:0.17.3-1.fc16
Mode is ud for provider of libpoppler.so.17: poppler.i686 0:0.17.3-1.fc16
Mode for pkg providing libpoppler.so.17: ud
Trying to update tracker-0.12.1-2.fc16.i686 to resolve dep
poppler-utils-0.17.3-1.fc16.i686 requires: libpoppler.so.17
--> Processing Dependency: libpoppler.so.17 for package: poppler-utils-0.17.3-1.fc16.i686
Needed Require has already been looked up, cheating
Potential Provider: poppler.i686 0:0.17.3-1.fc16
Mode is ud for provider of libpoppler.so.17: poppler.i686 0:0.17.3-1.fc16
Mode for pkg providing libpoppler.so.17: ud
Trying to update poppler-utils-0.17.3-1.fc16.i686 to resolve dep
poppler-glib-0.17.3-1.fc16.i686 requires: poppler = 0.17.3-1.fc16
--> Processing Dependency: poppler = 0.17.3-1.fc16 for package: poppler-glib-0.17.3-1.fc16.i686
poppler-utils-0.17.3-1.fc16.i686 requires: poppler = 0.17.3-1.fc16
--> Processing Dependency: poppler = 0.17.3-1.fc16 for package: poppler-utils-0.17.3-1.fc16.i686
---> Package poppler.i686 0:0.18.0-1.fc16 will be an update
Checking deps for poppler.i686 0:0.18.0-1.fc16 - u
--> Running transaction check
---> Package poppler-glib.i686 0:0.17.3-1.fc16 will be updated
Checking deps for poppler-glib.i686 0:0.17.3-1.fc16 - ud
---> Package poppler-glib.i686 0:0.18.0-1.fc16 will be an update
Checking deps for poppler-glib.i686 0:0.18.0-1.fc16 - u
looking for ('poppler', 'EQ', ('0', '0.18.0', '1.fc16')) as a requirement of poppler-glib.i686 0:0.18.0-1.fc16 - u
looking for ('libpoppler.so.18', None, (None, None, None)) as a requirement of poppler-glib.i686 0:0.18.0-1.fc16 - u
---> Package poppler-utils.i686 0:0.17.3-1.fc16 will be updated
Checking deps for poppler-utils.i686 0:0.17.3-1.fc16 - ud
---> Package poppler-utils.i686 0:0.18.0-1.fc16 will be an update
Checking deps for poppler-utils.i686 0:0.18.0-1.fc16 - u
looking for ('poppler', 'EQ', ('0', '0.18.0', '1.fc16')) as a requirement of poppler-utils.i686 0:0.18.0-1.fc16 - u
looking for ('libpoppler.so.18', None, (None, None, None)) as a requirement of poppler-utils.i686 0:0.18.0-1.fc16 - u
---> Package tracker.i686 0:0.12.1-2.fc16 will be updated
Checking deps for tracker.i686 0:0.12.1-2.fc16 - ud
---> Package tracker.i686 0:0.12.4-1.fc16 will be an update
Checking deps for tracker.i686 0:0.12.4-1.fc16 - u
--> Finished Dependency Resolution
Dependency Process ending
Running "postresolve" handler for "langpacks" plugin
Depsolve time: 0.533

Dependencies Resolved

===================================================================
 Package           Arch   Version          Repository         Size
===================================================================
Updating:
 evince            i686   3.2.0-2.fc16     updates-testing   1.6 M
Updating for dependencies:
 evince-libs       i686   3.2.0-2.fc16     updates-testing   261 k
 evince-nautilus   i686   3.2.0-2.fc16     updates-testing    28 k
 poppler           i686   0.18.0-1.fc16    fedora            626 k
 poppler-glib      i686   0.18.0-1.fc16    fedora             96 k
 poppler-utils     i686   0.18.0-1.fc16    fedora            159 k
 tracker           i686   0.12.4-1.fc16    updates-testing   1.2 M

Transaction Summary
===================================================================
Upgrade       7 Packages

Total size: 3.9 M
Is this ok [y/N]: y
Downloading Packages:
Running "predownload" handler for "presto" plugin
using local copy of poppler-0.18.0-1.fc16.i686
using local copy of evince-3.2.0-2.fc16.i686
using local copy of evince-nautilus-3.2.0-2.fc16.i686
using local copy of poppler-utils-0.18.0-1.fc16.i686
using local copy of tracker-0.12.4-1.fc16.i686
using local copy of evince-libs-3.2.0-2.fc16.i686
using local copy of poppler-glib-0.18.0-1.fc16.i686
Member: poppler-utils.i686 0:0.17.3-1.fc16 - ud
Member: poppler.i686 0:0.18.0-1.fc16 - u
Adding Package poppler-0.18.0-1.fc16.i686 in mode u
Member: evince-nautilus.i686 0:3.1.90-2.fc16 - ud
Member: evince.i686 0:3.1.90-2.fc16 - ud
Member: evince.i686 0:3.2.0-2.fc16 - u
Adding Package evince-3.2.0-2.fc16.i686 in mode u
Member: evince-nautilus.i686 0:3.2.0-2.fc16 - u
Adding Package evince-nautilus-3.2.0-2.fc16.i686 in mode u
Member: poppler-utils.i686 0:0.18.0-1.fc16 - u
Adding Package poppler-utils-0.18.0-1.fc16.i686 in mode u
Member: tracker.i686 0:0.12.1-2.fc16 - ud
Member: poppler-glib.i686 0:0.17.3-1.fc16 - ud
Member: evince-libs.i686 0:3.1.90-2.fc16 - ud
Member: tracker.i686 0:0.12.4-1.fc16 - u
Adding Package tracker-0.12.4-1.fc16.i686 in mode u
Member: evince-libs.i686 0:3.2.0-2.fc16 - u
Adding Package evince-libs-3.2.0-2.fc16.i686 in mode u
Member: poppler-glib.i686 0:0.18.0-1.fc16 - u
Adding Package poppler-glib-0.18.0-1.fc16.i686 in mode u
Member: poppler.i686 0:0.17.3-1.fc16 - ud
Running Transaction Check
ERROR with transaction check vs depsolve:
libpoppler.so.17 is needed by tracker-0.12.4-1.fc16.i686
Please report this error in http://yum.baseurl.org/report
 You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2011-10-11-19-13pG8c08.yumtx


I would expect that it would calculate the dependencies correctly up front in all cases.
Comment 1 James Antill 2011-10-11 17:30:06 EDT
*** Bug 745206 has been marked as a duplicate of this bug. ***
Comment 2 James Antill 2011-10-17 12:03:06 EDT
This should be fixed in the latest yum in rawhide.

Note You need to log in before you can comment on or make changes to this bug.