Bug 745246 - Need automatic conversion from grub1 to grub2 for all possible cases
Need automatic conversion from grub1 to grub2 for all possible cases
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 14:48 EDT by Tom "spot" Callaway
Modified: 2013-05-31 13:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 17:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2011-10-11 14:48:25 EDT
Since the plan is to force a replacement of grub2 (removing grub1) on upgrades, we need to do an automatic conversion from grub1 to grub2 configs on the system at that time, excluding any cases which are known not to work.

This can probably be done either in post or with a %triggerun.

In the case of password enabled grub1 configs, we should consider simply deploying a working grub2 config without the password, if possible, as that is better than a non-booting system IMHO.
Comment 1 Adam Williamson 2011-10-11 19:08:07 EDT
-1 blocker: we are already doing this with supported upgrade methods (anaconda-based). upgrading with yum is not a support method and is not included in the release criteria.
Comment 2 Adam Williamson 2011-10-13 17:22:52 EDT
one obvious consideration is that we shouldn't try to convert EFI systems to grub2. I believe the script could check if the system's EFI based by looking for some file or other in /sys which only shows up if the system's EFI-booted, though.
Comment 3 Adam Williamson 2011-10-14 13:56:36 EDT
Discussed at 2011-10-14 blocker review meeting. Agreed this is not a blocker as we do not support yum upgrades, and in any case doing a yum upgrade does not result in a non-bootable configuration as grub remains in the MBR or boot sector and its configuration file remains in place.
Comment 4 Nadav Har'El 2011-11-10 10:30:53 EST
I just upgraded, using "preupgrade", two Fedora 15 systems to Fedora 16, and in both systems the upgrade did NOT replace grub1 with grub2, and I was left running grub1 configured to run an old Fedora 15 kernel (which was luckily not deleted yet). I had to manually run on each system:

    /sbin/grub2-mkconfig -o /boot/grub2/grub.cfg
    /sbin/grub2-install BOOTDEVICE

(as recommended in http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_15_-.3E_Fedora_16)
Which worked correctly, and now Fedora boots to the new Fedora 16 kernel.

Someone above commented that "upgrading with yum is not a support method". Preupgrade is also not supported??? That would be utterly ridiculous, since *everybody* I know uses only this method to upgrade. The last time I actually burnt a DVD of Fedora was when I wanted to install it on a new machine. Preupgrade is much more convenient, and also much faster, and there is no reason why it should work. So would a big boot message (or whatever) urging you to quickly run these commands, or you risk running an old kernel which will most likely be automatically deleted from your system after a few updates.

Thanks.
Comment 5 Nadav Har'El 2011-11-10 11:18:24 EST
I just noticed that this bug is a duplicate of bug 737731
Comment 6 Mads Kiilerich 2011-11-10 11:53:14 EST
(In reply to comment #5)
> I just noticed that this bug is a duplicate of bug 737731

No; this bug is a catch-all for all upgrade methods, not limited to preupgrade as bug 737731.

(In reply to comment #4)
> I just upgraded, using "preupgrade", two Fedora 15 systems to Fedora 16, and in
> both systems the upgrade did NOT replace grub1 with grub2, and I was left

Yes, that is a bug. It sounds like https://fedoraproject.org/wiki/Common_F16_bugs#preupgrade-bootloader-fail but might be something else.

> Someone above commented that "upgrading with yum is not a support method".
> Preupgrade is also not supported???

Preupgrade is not yum upgrade. Preupgrade is supported, yum isn't.
Comment 7 Nadav Har'El 2011-11-10 12:05:05 EST
Thanks for all the explanations. One nitpick: https://fedoraproject.org/wiki/Common_F16_bugs#preupgrade-bootloader-fail should mention Fedora *15*, not 14. I preupgraded from Fedora 15, not 14.
Comment 8 Mads Kiilerich 2011-11-10 12:18:52 EST
(In reply to comment #7)
> https://fedoraproject.org/wiki/Common_F16_bugs#preupgrade-bootloader-fail
> should mention Fedora *15*, not 14. I preupgraded from Fedora 15, not 14.

No. But there is no reason to discuss that on two bugs at once. goto bug 737731.
Comment 9 Mads Kiilerich 2012-04-16 17:35:04 EDT
This issue was solved for f16 by anaconda by default installing the new bootloader. The guidelines for manual upgrade with yum also mentioned that the new boot loader had to be installed.

Marking as closed.

Note You need to log in before you can comment on or make changes to this bug.