Bug 745304 - email tag followed by punctuation results in an extra space that cannot be removed
email tag followed by punctuation results in an extra space that cannot be re...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.7
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 20:33 EDT by Murray McAllister
Modified: 2015-01-04 17:36 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to restore mixed mode on email tag (1.11 KB, patch)
2012-04-29 08:57 EDT, Raphaël Hertzog
no flags Details | Diff

  None (edit)
Description Murray McAllister 2011-10-11 20:33:34 EDT
Description of problem:

Not sure if this can be fixed in Publican. If punctuation (I only tried : and
,) is used after the email tag, a space is added that cannot be removed.

Version-Release number of selected component (if applicable):
publican-2.7-1
firefox-3.6.23-2.el6_1.x86_64
Red Hat Enterprise Linux Workstation release 6.1 (Santiago)

How reproducible:
Always, for me.

Steps to Reproduce:
1. use a . or a : after an email tag, for example:

Email <email>this@test.com</email>. to

End of the line <email>another@test.com</email>.(\n)

2. Build with the common brand in the txt, html, html-single, and pdf formats.

Actual results:
Email this@test.com . to

End of the line another@test.com .

Expected results:
Email this@test.com. to

End of the line another@test.com.
Comment 1 Jeff Fearn 2011-10-11 20:47:00 EDT
No newline after email when inline!

Applied fix to branches/publican-2x and trunk.

Committed revision 1917.
Comment 2 Laura Novich 2012-04-24 08:12:02 EDT
I put the lines into another document, and the problem still exists
Comment 3 Raphaël Hertzog 2012-04-25 16:47:07 EDT
I have a similar problem with the git version of 27th march of this year. So whatever was the fix that got committed, it's not enough yet.

In my case, I saw it in a build of a translation. And the problem is really that it inserts a spurious newline but also tabs to indent the content.
Comment 4 Raphaël Hertzog 2012-04-29 08:57:15 EDT
Created attachment 581063 [details]
Patch to restore mixed mode on email tag

Please find attached a patch that fixes the issue by restoring the mixed_mode attribute that was present in publican 2.9 but was lost in publican 3.0.
Comment 5 Jeff Fearn 2012-05-16 22:57:23 EDT
Confirm mixed_mode lost during code merge.

Patch applied.

To ssh://git.fedorahosted.org/git/publican.git
   5000dcf..2e04033  master -> master
Comment 6 Michael Hideo 2012-06-07 21:45:04 EDT
create book, include body text that is inside an email tag. follow the email tag with punctuation, build book, hope that ther eis no space between email tag and punctuation.
Comment 7 Stephen Gordon 2012-06-08 11:57:47 EDT
Verified on publican-3.0-0.fc17.t179, in both PDF and HTML formats extra space is no longer inserted in output between <email>...</email> tags and following punctuation.

Note You need to log in before you can comment on or make changes to this bug.