Bug 745420 - libssh2 sftp_RW_nonblock upstream example test fail
libssh2 sftp_RW_nonblock upstream example test fail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libssh2 (Show other bugs)
6.2
All Linux
low Severity low
: rc
: ---
Assigned To: Kamil Dudka
Karel Srot
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 06:13 EDT by David Spurek
Modified: 2015-03-02 00:26 EST (History)
5 users (show)

See Also:
Fixed In Version: libssh2-1.4.2-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:42:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2011-10-12 06:13:56 EDT
Description of problem:
libssh2 sftp_RW_nonblock upstream example test always fail with:
Authentication by password failed

Version-Release number of selected component (if applicable):
libssh2-1.2.2-7.el6_1.1.src.rpm

How reproducible:
always

Steps to Reproduce:
1.build libssh2-1.2.2-7.el6_1.1.src.rpm (rpmbuild -vv -bc $HOME/rpmbuild/SPECS/libssh2.spec)
2.cd $HOME/rpmbuild/BUILD/libssh2-1.2.2/example/simple/
3.run:
./sftp_RW_nonblock username password sftppath dest
  
Actual results:
Authentication by password failed
all done

Expected results:
example success
Comment 1 Kamil Dudka 2011-10-24 10:37:58 EDT
patch sent upstream:

http://thread.gmane.org/gmane.network.ssh.libssh2.devel/5280
Comment 2 Kamil Dudka 2011-10-24 16:52:00 EDT
pushed upstream:

http://git.libssh2.org/?p=libssh2.git;a=commitdiff;h=c0974e5
Comment 6 Suzanne Yeghiayan 2012-02-14 18:17:24 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 RHEL Product and Program Management 2012-09-12 08:21:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 14 errata-xmlrpc 2013-02-21 03:42:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0329.html

Note You need to log in before you can comment on or make changes to this bug.