Bug 74546 - Deleted random packages on cancel
Deleted random packages on cancel
Status: CLOSED DUPLICATE of bug 74958
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-26 09:40 EDT by James Antill
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 15:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2002-09-26 09:40:23 EDT
Description of Problem:
 I ran redhat-config-packages, click to install some new packages and clicked to
remove some I didn't need. Then clicked "update", it said it was "preparing to
install/delete" then it said insert CD 1 of Psyche. I didn't have a CD, so I
clicked cancel ... it then did something (with the UI hung) for about 5 minutes.
After that, I ran it again and it said I didn't have gnome installed ...
worrying slightly about what it had done I rebooted. At least the following
happened:

 GDM was deleted, and has been replaced with kdm in the startup.
 evolution has been deleted.
 Multiload applet has been deleted.

 I hadn't requested any of these packages to be deleted, it's also
possible/likely that other things have gone.

Version-Release number of selected component (if applicable):
 redhat-config-packages-1.0.1-1

How Reproducible:
 Unknown.

Steps to Reproduce:
1. click to add a bunch of packages, and delete a bunch of different ones.
2. click "upgrade"
3. click "cancel" at CD insert prompt.

Actual Results:
 Random packages deleted.

Expected Results:
 Either just the reqeusted deleted packages to be deleted ... or do nothing as
the installs cannot be satisfied.

Additional Information:
	It's pretty hard to work out what I need to install to make "gnome" thinks it's
installed again ... probably some of the standard packages got deleted, but it's
not easy to see which.
Comment 1 Jeremy Katz 2002-10-01 18:07:10 EDT
I can't reproduce this here -- are you sure you didn't select to remove a lot of
packages and maybe that removal got moved to the beginning of the transaction set?
Comment 2 James Antill 2002-10-01 19:29:35 EDT
 As I said, I did select to have _some_ removed ... but not all of the ones that
got deleted (specifically gnome-applets, gnome-games, evolution, nautilus and
gdm were _NOT_ selected for removal -- and they were gone).
 I guess it's possible that I decided to have a dependancy of those removed, by
accident, however it didn't tell me it was going to remove them. Also I have
since used redhat-config-packages to just add things (when I have the CDs), and
if you have to click cancel[1] then it returns very quickly ... when the above
problem occured a _lot_ of disk activity happened after I clicked cancel and
before the program exited. I assume this is when the packages were deleted that
I didn't want deleted ... but it's hard to say.
 In theory I could try creating the problem again, but I don't have a test
machine ... the above was done with my company laptop and I had to spend time
the next day downloading a version of evolution so I could read my work email.

[1] some rpm was required by firstboot before it would do anything, and I
manually installed it ... but it only looks at rpms installed when you start it.
Comment 3 Jeremy Katz 2002-10-11 15:43:27 EDT
Did you possibly select authoring/publishing for removal?
Comment 4 James Antill 2002-10-11 15:55:41 EDT
 I can't guarantee it, but it's likely.
Comment 5 Jeremy Katz 2002-10-11 16:24:17 EDT

*** This bug has been marked as a duplicate of 74958 ***

Note You need to log in before you can comment on or make changes to this bug.