Bug 74556 - KDE login/unlock fails for nisplus users when RedHat 7.0 was installed with GNOME default desktop
KDE login/unlock fails for nisplus users when RedHat 7.0 was installed with G...
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-26 12:26 EDT by Philippe Scelers
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:25:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philippe Scelers 2002-09-26 12:26:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.17-21mdk i686)

Description of problem:
When RedHat 7.0 was installed with GNOME default desktop, KDE login and KDE
unlock screen fails for nisplus users.
Everything works well for local user, tested only as 'root' 

Everything works well for all users, including nisplus users, when using GNOME
desktop (the one selected at installation time).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RedHat 7.0, select GNOME as the default desktop
2.Configure to use nisplus for users
3.GNOME login: login nisplus user, select KDE desktop
4.Lock the screen
5.unlock the screen => ALWAYS FAILS
6.Ctrl+Alt+F2 to switch to virtual terminal
7.login root and kill KDE screen lock process
8.Ctrl+At+F7 to switch to KDE, the screen is unlocked

	

Actual Results:  I must kill the KDE screen lock using virtual terminal or
remote login from other host.

BUG: pam setup only for GNOME, 
Workaround: to fix all the problems,
I should copy the GNOME file into the KDE file.
  % cp /etc/pam.d/gdm /etc/pam.d/kde
  % reboot

Expected Results:  Should work

Additional info:

The problem is critical when switching default desktop from GNOME to KDE (file
/etc/sysconfig/desktop:DESKTOP="KDE" + reboot).
nisplus users login always fails.
Workaroung switch desktop to GNOME from a virtual terminal and reboot
Comment 1 Bastien Nocera 2002-09-26 12:38:06 EDT
This is actually a bug in the /etc/pam.d/kde file, from kdebase.
Comment 2 Bastien Nocera 2002-09-26 12:39:04 EDT
Forgot to change owner, sorry.
Comment 3 Petr Rockai 2006-07-17 14:24:48 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 4 Bill Nottingham 2006-10-18 14:25:34 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.