This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 745625 - sysVinit script Required-Start parameters are not parsed by systemd
sysVinit script Required-Start parameters are not parsed by systemd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: James C.
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 16:59 EDT by Michael Cronenworth
Modified: 2012-04-16 21:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 21:22:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2011-10-12 16:59:06 EDT
Description of problem:
syslog output: 
[/etc/rc.d/init.d/cobblerd:10] Failed to add dependency on network,.service, ignoring: Invalid argument
[/etc/rc.d/init.d/cobblerd:10] Failed to add dependency on xinetd,.service, ignoring: Invalid argument

Version-Release number of selected component (if applicable):
cobbler-2.0.11-2.fc15.noarch
systemd-26-10.fc15.x86_64

How reproducible: Always


Steps to Reproduce:
- Install cobbler.
- Check syslog.
- Install or update other software that reloads systemd.
  
Actual results:
Error message in syslog.


Expected results:
Correct requires are read and setup by systemd.

Additional info:
I filed this against cobbler because I feel it should transition to a systemd unit file and this is just a reason to push it.

I'm not sure if the Required-Start spec calls for comma-delimited services, but if it does then I guess it is a systemd bug.
Comment 1 Fedora Admin XMLRPC Client 2012-04-11 18:00:37 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 James C. 2012-04-16 21:22:05 EDT
This issue has been corrected as of the 2.2.0 release, which will use systemd when available. If you continue to have problems, please open a new issue via the github issue tracker: https://github.com/cobbler/cobbler/issues

Note You need to log in before you can comment on or make changes to this bug.