This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 745711 - virtio cannot transfer all guest anaconda logs to host
virtio cannot transfer all guest anaconda logs to host
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
RejectedNTH
:
Depends On: 744544
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-13 03:31 EDT by Ales Kozumplik
Modified: 2014-09-30 19:40 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 744544
Environment:
Last Closed: 2011-10-17 01:49:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2011-10-13 03:31:01 EDT
Cloning this to propose as an F16 blocker.

+++ This bug was initially created as a clone of Bug #744544 +++

Created attachment 527084 [details]
analog

Description of problem:
It fails to transfer all anaconda logs of guest to the host by serial virtio. only the syslog is transferred.

Version-Release number of selected component (if applicable):

host is F15 with libvirt-0.8.8-7.fc15.x86_64, virt-manager-0.8.7-6.fc15.noarch
guest is F16 Beta gold (F16 beta rc4)

How reproducible:
100%

Steps to Reproduce:
1. add virtio-serial port on the guest with virsh edit
2. run analog to start listening to the guest
3. start guest
  
Actual results:


Expected results:


Additional info:
This blocks the Fedora installation test automation project, hope you can give it high priority. Thanks.

--- Additional comment from hoyang@redhat.com on 2011-10-09 06:42:54 EDT ---

Created attachment 527085 [details]
anaconda logs

--- Additional comment from akozumpl@redhat.com on 2011-10-10 11:14:02 EDT ---

I can confirm this, though this is not a bug in analog. Apparently the rsyslog format of forwarded messages has changed between the two versions and what is forwarded from F16 rsyslogd (the one running in your guest) is not correctly parsed by the receiving F15 rsyslogd (the one where analog is running). You should be able to confirm this e.g. by looking at debug_unknown_source.log which contains all the messages where we failed to recognize the tag.

Reassigning to rsyslogd which maintainer might or might not be able to help you.

The easiest fix for you is in any case upgrading your host rsyslogd to the same version the tested guest is running.

--- Additional comment from akozumpl@redhat.com on 2011-10-11 09:09:02 EDT ---

We clarified this with theinric and the error is not because of a new rsyslog version but rather due to changed environment in F16 --- something we can fix in the image generation.

--- Additional comment from akozumpl@redhat.com on 2011-10-11 09:57:21 EDT ---

Patch posted: https://www.redhat.com/archives/anaconda-devel-list/2011-October/msg00065.html

--- Additional comment from akozumpl@redhat.com on 2011-10-12 04:28:23 EDT ---

Fixed by e61f3b23d47903b30ac0ce591a200dc5edc4f979. This will be part of the first f17 compose.

Hongqing,

Will it be OK to have this in F17 only?

--- Additional comment from hoyang@redhat.com on 2011-10-12 22:24:09 EDT ---

(In reply to comment #5)
> Fixed by e61f3b23d47903b30ac0ce591a200dc5edc4f979. This will be part of the
> first f17 compose.
> 
> Hongqing,
> 
> Will it be OK to have this in F17 only?

Ales, 
It would be better if you can correct it in F16 Final, since the new environment in F16, I have to update the test scripts accordingly, so I need a working media to test. Thanks.
Comment 1 Ales Kozumplik 2011-10-13 03:37:51 EDT
I pushed this to f16-branch in lorax as b0e5b51be7cc5ca362612c0fe212814a2886a4cf. The only way to ensure this is going to make f16 is to have this accepted as a NTH. Proposed as such: the fix allows the autoQA project Hongqing is working on to continue.
Comment 2 Adam Williamson 2011-10-14 14:38:50 EDT
Discussed at 2011-10-14 NTH review meeting. As mentioned in some bugs last week, we cannot base our NTH decisions on anaconda commit policies: this bug is not significant enough to warrant touching anaconda in a freeze, and hence we reject it as NTH. For AutoQA we can build custom images if necessary.

Note You need to log in before you can comment on or make changes to this bug.