Bug 74582 - Postinstall hangs on Dell GX400 (no %post defined)
Postinstall hangs on Dell GX400 (no %post defined)
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-09-26 16:53 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-05 13:44:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-26 16:53:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
KickStart gets IP, partitions, installs pkgs fine  - then hangs at Postinstall.
Alt-F4 reports:
<6>attempt to access beyond end of device ...
<4>Error -3 while decompressing.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Use attached ks.cfg file
2. Attempt to install
3. Watch Alt-F4 output, until Postinstall.

Actual Results:  Postinstall hangs halfway through and reports:
<6>attempt to access beyond end of device
<6>01:01: rw=0, want=4846, limit=4608
<4>Error -3 while decompressing.

Expected Results:  I believe KickStart should have installed correctly (it has
worked flawlessly in the past on same machine with RH 7.2). Sorry if I am
missing something obvious. :)

Additional info:

The machine in question is a Dell GX400 with a Western Digital 40 GB HDD (CHS:
4865/255/63 in dmesg). A similar ks.cfg worked fine on the same machine when
installing RH 7.2.


auth  --enablemd5  --enableshadow
clearpart --linux
firewall --disabled
  url --url ftp://anonymous:@[SOME_SERVER]/pub/redhat-7.3
keyboard us
lang en_US
langsupport en_US
mouse genericps/2 --device psaux --emulthree
network --bootproto dhcp
part /boot --fstype ext3 --size 20
part / --fstype ext3 --size 7000 --ondisk hda
part  swap --size 256 --ondisk hda
rootpw --iscrypted .....
timezone --utc America/Chicago
xconfig  --depth 16 --resolution 1024x768 --defaultdesktop=GNOME --startxonboot

@Network Support
Comment 1 Michael Fulbright 2002-09-27 15:22:24 EDT
Is the machine completely unresponsive, or can you change VC's, etc?
Comment 2 Need Real Name 2002-09-28 10:58:33 EDT
It's not completely unresponsive. I can change VC's, but I believe when I went
to the shell VC, I kept getting permission denied errors for the usual commands
(ls, cd, etc.) I am going to use the same ks.cfg with RH 7.2 Monday to debug
Comment 3 Need Real Name 2002-10-07 16:57:30 EDT
Sorry for the delay.

I have been able to install RH 7.2 (only) via KickStart on the Dell, but only
with a / part size of 7 GB and a swap of 256 MB. I have tried larger /
partitions but it failed. I have been unable to install RH 7.3 or RH 8.0: 7.3
throws a warning:

"WARNING: Boot partition / may not meet booting constraints for your
architecture. Creation of a boot disk is highly recommended." 

and hangs at the postinstall; 8.0 gives an error about being unable to retrieve
the first install image. RH 7.2, 7.3, and 8.0 are able to install without error
or snafu from the same FTP server when installed by hand (without KickStart).
The machine (Dell GX400) is used in two labs of about 20-25 computers each. We
used to install RH 7.2 in the labs with KickStart, but kept the / partition down
to 5-6 GB (because the machines are NIS/NFS clients). Since then we have been
using imaging software. This may just be a problem with this particular machine
and might be related to the following KickStart Mailing List post:


We will probably just solve the problem by installing RH 8.0 on a machine and
imaging the rest of them, but if any more debugging might help, please do not
hesitate to ask. 

Thanks for your help.
Comment 4 Jeremy Katz 2002-10-24 15:27:59 EDT
Are you passing the proper ramdisk_size option to the kernel when you are
booting? (used by syslinux, but if you're booting with something other than our
boot disks, you need to make sure it's specified)
Comment 5 Need Real Name 2002-10-31 18:56:08 EST
I am using the default bootnet.img images. Using the ks.cfg and syslinux.cfg
recommended in the Customization Guide.
Comment 6 Jeremy Katz 2002-11-05 13:15:43 EST
So the syslinux.cfg is the same as the one on bootnet?
Comment 7 Need Real Name 2002-11-05 13:43:57 EST
syslinux.cfg used is as follows:

default ks
prompt 0
timeout 600
label ks
  kernel vmlinuz
  append ks=floppy initrd=initrd.img
Comment 8 Jeremy Katz 2002-11-05 13:52:24 EST
You need to add ramdisk_size=8192 to the append line.
Comment 9 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 10 Need Real Name 2002-12-20 15:51:59 EST
Adding ramdisk_size=9216 (for RH8) works fine, I imagine that defining the size
will work similarly for RH7.2 and RH7.3. Sorry for the delay (busy semester),
but thank you very much for your help. You people rock.

Happy Holidays!

Note You need to log in before you can comment on or make changes to this bug.