Bug 746084 - matahari services missing from chkconfig
matahari services missing from chkconfig
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Zane Bitter
IDM QE LIST
:
Depends On:
Blocks: 748554
  Show dependency treegraph
 
Reported: 2011-10-13 16:28 EDT by Dave Johnson
Modified: 2011-12-06 06:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description required.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 06:45:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2011-10-13 16:28:04 EDT
Description of problem:
============================
Summary says it all, after installing matahari on a fresh os I noticed that none of the services are in the chkconfig --list output.  They can be manually added by running 'chkconfig --add service-name'.

Also, not sure if this is an additional issue but when chasing this bug, I looked at the init script and noticed that the Provides value is not filled in for any of the matahari services. 
    ### BEGIN INIT INFO
    # Provides:
    # Required-Start: $local_fs matahari-broker

Compared to libvirt-qmf which does have a value.
    ### BEGIN INIT INFO
    # Provides: libvirt-qmf
    # Should-Start: libvirtd

This is the case on all arches

Version-Release number of selected component (if applicable):
=================================================================
matahari-0.4.4-8.el6.ppc64
matahari-agent-lib-0.4.4-8.el6.ppc64
matahari-broker-0.4.4-8.el6.ppc64
matahari-consoles-0.4.4-8.el6.ppc64
matahari-host-0.4.4-8.el6.ppc64
matahari-lib-0.4.4-8.el6.ppc64
matahari-network-0.4.4-8.el6.ppc64
matahari-service-0.4.4-8.el6.ppc64
matahari-sysconfig-0.4.4-8.el6.ppc64
Comment 2 Dave Johnson 2011-10-13 23:22:12 EDT
Thinking about how to implement some test automation intelligence to run test variants depending on their arch I came across this web page which is making me question if matahari services for Fedora are properly configured for startup on next boot.  

http://fedoraproject.org/wiki/SysVinit_to_Systemd_Cheatsheet


[root@localhost ~]# ls /etc/systemd/system/*.wants/matahari*
ls: cannot access /etc/systemd/system/*.wants/matahari*: No such file or directory

[root@localhost ~]# ls /etc/systemd/system/*.wants
/etc/systemd/system/default.target.wants:
systemd-readahead-collect.service  systemd-readahead-replay.service

/etc/systemd/system/getty.target.wants:
getty@tty1.service  getty@tty2.service  getty@tty3.service  getty@tty4.service  getty@tty5.service  getty@tty6.service

/etc/systemd/system/multi-user.target.wants:
crond.service  remote-fs.target  rsyslog.service

/etc/systemd/system/sysinit.target.wants:
hwclock-load.service
[root@localhost ~]#
Comment 3 Zane Bitter 2011-10-18 09:52:00 EDT
Fix committed to spec file in upstream repo:
https://github.com/matahari/matahari/commit/8641b688e1d9a6530746d41c87fe326b202661ec
Comment 9 Dave Johnson 2011-11-03 18:35:57 EDT
good to go in v0.4.4-9
Comment 10 Russell Bryant 2011-11-16 17:29:30 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required.
Comment 11 errata-xmlrpc 2011-12-06 06:45:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html

Note You need to log in before you can comment on or make changes to this bug.