Bug 74623 - error message (deprecated python calls)
error message (deprecated python calls)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
: 84284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 17:32 EDT by Chris Ricker
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 10:19:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-09-27 17:32:14 EDT
Running redhat-config-xfree86 on RHL 8 gives me

[root@dartagnan root]# redhat-config-xfree86
/usr/share/redhat-config-xfree86/xconf.py:1238: DeprecationWarning:
  self.xml.get_widget("display_dialog").set_uposition(xpos, ypos)
[root@dartagnan root]#
Comment 1 Alexander Larsson 2002-10-02 03:15:59 EDT
Maybe we can get away with usign window.set_position(center). Need to try that.
Otherwise I don't see much that can be done.
Comment 2 Brent Fox 2002-12-15 10:19:31 EST
Fixed in cvs by replacing set_uposition with set_position(gtk.WIN_POS_CENTER). 
Thanks for your report.



RCS file: /usr/local/CVS/redhat-config-xfree/src/xconf.py,v
retrieving revision 1.38
retrieving revision 1.39
diff -u -r1.38 -r1.39
--- xconf.py    13 Dec 2002 20:43:58 -0000      1.38
+++ xconf.py    13 Dec 2002 23:05:35 -0000      1.39
@@ -50,7 +50,7 @@
     if xserverpid:
         xpos = gtk.gdk.screen_width() / 2 - dialog.size_request()[0] / 2
         ypos = gtk.gdk.screen_height() / 2 - dialog.size_request()[1] / 2
-        dialog.set_uposition(xpos, ypos)
+        dialog.set_position(gtk.WIN_POS_CENTER)
Comment 3 Brent Fox 2003-02-13 21:19:46 EST
*** Bug 84284 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.