Bug 74636 - netatalk afpd looks for configuration file in wrong location
netatalk afpd looks for configuration file in wrong location
Status: CLOSED DUPLICATE of bug 69647
Product: Red Hat Linux
Classification: Retired
Component: netatalk (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 22:58 EDT by subtlegrace
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-27 22:59:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description subtlegrace 2002-09-27 22:58:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
Editing /etc/atalk/afpd.conf has no effect whatsoever on netatalk. No mater 
what changes are made to the configuration file, netatalk runs under the 
default options, as though the configuration file had never been edited.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. edit /etc/atalk/afpd.conf and add a line at the bottom reading:
   "Guest Volume" -uamlist uams_guest.so
2. As root, do: service atalk restart
3. Try to log in as a Guest user from a Macintosh on the network.
	

Actual Results:  When trying to log in from a Macintosh on the network, I find 
the "Guest" option greyed out and unavailable - netatalk refuses to let me log 
in as a guest user. I am only given the option to log in as a Registered User.

Expected Results:  "Log in as Guest User" should have been an available option 
when trying to log in from the Macintosh.

Additional info:

After a little investigation, I found that if you do:
strings `which afpd` | grep afpd.conf

You will get:
/usr/etc/netatalk/afpd.conf

This is the wrong location. Netatalk should be looking for that file 
in /etc/atalk/afpd.conf instead.

My current workaround solution is to do (as root): 
ln -s /usr/etc/netatalk /etc/atalk

This, however, is not an optimal solution - I believe that the Netatalk rpm 
has been incorrectly compiled. It would be better if Netatalk looked for the 
configuration file in its correct location.
Comment 1 Phil Knirsch 2002-09-28 02:43:28 EDT

*** This bug has been marked as a duplicate of 69647 ***

Note You need to log in before you can comment on or make changes to this bug.