Bug 74638 - trident blade3d 9880 & xfree 4.2.0 DO NOT MIX
trident blade3d 9880 & xfree 4.2.0 DO NOT MIX
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-28 01:52 EDT by Stig Hackvan
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 05:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2002-09-28 01:52:47 EDT
Description of Problem:

a system running a trident blade3d 9880 AGP card sets up just fine.  it also
works wonderfully in 1024x768 framebuffer mode in the console (vga=788), and it
even configures wonderfully for X11, but it just doesn't stay running.

it seems that something in gtk tickles something in xfree's trident driver that
causes the machine to reproducibly freeze up.



Version-Release number of selected component (if applicable):

XFree86-xfs-4.2.0-8
XFree86-base-fonts-4.2.0-8
XFree86-ISO8859-15-100dpi-fonts-4.2.0-8
XFree86-font-utils-4.2.0-8
XFree86-75dpi-fonts-4.2.0-8
XFree86-4.2.0-8
XFree86-ISO8859-15-75dpi-fonts-4.2.0-8
XFree86-twm-4.2.0-8
XFree86-devel-4.2.0-8
XFree86-libs-4.2.0-8
XFree86-100dpi-fonts-4.2.0-8
XFree86-tools-4.2.0-8
XFree86-xdm-4.2.0-8

--- with or without ximian's libraries i had the crashes, but it was clockwork
with ximian's red-carpet...

red-carpet-1.3.4-1.ximian.3
gtk+-devel-1.2.10-15.ximian.31
gtk+-1.2.10-15.ximian.31




How Reproducible:

1) redhat-only rpms: seem to recall getting the behavior when closing galeon
windows via the sawfish X-box...

2) install ximian on top of an up-to-date redhat-73.
   - restart (probably just restarting x11 is plenty)
   - as root, 'red-carpet &' 
     / click unsubscribed channels 
     / click redhat 73 
     / click subscribe
   - BLAMMO!  YOU NOW HAVE A FROZEN COMPUTER!  
     (OR AT LEAST I DO, REPEATBLY, EVERY TIME THIS IS TRIED)

Actual Results:

TOTALLY FROZEN SYSTEM.  DOES NOT RESPOND TO PING.  
DOES NOT RESPOND TO KEYBOARD.  ANIMATED EXCLAIMATION POINT IN REDHAT UPDATE
TOOLBAR DOES NOT BLINK.


Additional Information:
	
This guy had the same problem but doesn't seem to have filed a bug report.

  https://listman.redhat.com/pipermail/seawolf-list/2001-May/002549.html
Comment 1 Mike A. Harris 2002-09-28 11:24:58 EDT
DOES SHOUTING LIKE THIS MAKE YOU THINK THAT IT WILL GET THE PROBLEM
RESOLVED FASTER?

I don't see your video card listed as being a supported card in the
official XFree86 video hardware support status document for 4.2.0:

http://www.xfree86.org/4.2.0/Status33.html#33

Therefore, it appears that this isn't actually a bug, but rather that
your hardware is just unsupported.  Since I neither have this video
card, nor do I have the technical specifications for it because
Trident refuses to release such information to open source developers,
there's basically nothing I can do about this.

Your best recourse, is to post a POLITE email message to xpert@xfree86.org,
requesting driver support for this chip.  Alan Hourihane the Trident
driver maintainer reads that mailing list, and he might be able to
add support for it into some future release of XFree86.

Once it is supported by XFree86, it will be added to a future release
of Red Hat Linux.  In the mean time, you can try using the "vesa" driver.
Keep in mind though, that if the "vesa" driver does not work, it is
generally a bug in the video card's BIOS, and nothing that can be fixed.
Comment 2 Stig Hackvan 2002-09-30 01:28:15 EDT
THE 'Trident Blade3D' card IS listed as supported at
http://www.xfree86.org/4.2.0/Status33.html#33

and TYPING IN ALL CAPS is not shouting...it's highlighting...

the 'vesa' server doesn't crash on the same test cases that caused the trident
server to crash, but it also doesn't pick a sane modeline for my flatpanel
display  and the interaction between kernel framebuffer and xfree/vesa drivers
pooches the display...  xfree/fbdev doesn't seem to work right either...instead
of noticing that the kernel's using 1024x768, it switches to 800x600.




Comment 3 Stig Hackvan 2002-09-30 17:45:59 EDT
some of my peripheral difficulties with this configuration were snarks:
it turns out that the 'fbdev' xfree driver is a reasonable but slow workaround.
 the reason it came up 800x600 is that vga=788 was an 800x600 mode.  

i shall report the xfree/trident problem to xpert list, but since this is listed
as supported hardware, with multiple people having difficulties with it, then it
seems fitting that it be tracked here.

-- stig
Comment 4 Mike A. Harris 2002-10-25 23:53:23 EDT
1) Typing in all caps *is* shouting.  It's standard convention for electronic
   communication, and well accepted as being shouting by 99% of the community
   for well over 15 or more years.

2) <U>This is highlighting, if bugzilla interprets underline tags properly</U>

3) The Hardware compatibility list is not accurate.  That's not my problem
   because I do not have anything to do with determining what gets listed
   in the Hardware compatibility list.  I do however have everything to
   do with deciding what is and is not supported.  If something is not
   listed explicitly on XFree86.org's status page, then it might or might
   not work, however I consider it unsupported unless it appears there
   explicitly.  If it does appear there, it might or might not be considered
   supported depending on various factors.

It is fine to track your problem here if you like however.

Does disabling acceleration by using:  Option "noaccel" in your config
file (man XF86Config - if unfamiliar with this option) cause the problem
to go away?  If so, we can troubleshoot further to try and find the root
cause.
Comment 5 Mike A. Harris 2002-12-15 05:06:08 EST
Closing bug as I'm unable to do anything without receiving a response
to the question I asked in my last comment well over a month and a half
ago.

If this issue is still occuring and is considered important to you, please
provide the information requested and reopen the bug report.

Note You need to log in before you can comment on or make changes to this bug.