Bug 746553 - SPICE is undocumented
SPICE is undocumented
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
15
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Gerd Hoffmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 00:22 EDT by Pete Travis
Modified: 2012-06-02 15:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 15:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pete Travis 2011-10-17 00:22:33 EDT
Description of problem:
I don't know how to use SPICE, and I can't find any information from Fedora.


Version-Release number of selected component (if applicable):
current

My process is as follows:

[pete@thefool ~]$ man spicec
No manual entry for spicec

[pete@thefool ~]$ help spicec
bash: help: no help topics match `spice'.  Try `help help' or `man -k spice' or `info spice'.

[pete@thefool ~]$ spicec --help
spicec - Spice client

options:

      --version
                              spice client version
 <snip>

Now I know how spicec likes options passed to it.  What am I connecting to? how do I configure spice-server?

[pete@thefool ~]$ yum info spice-server
       (package overview, no usage info, but there is a url for spice-space.org where I can download .pdf documentation - this will help, but it really isn't optimal...)

so, I run a query with my search engine of choice:

Your search - site:http://docs.fedoraproject.org/en-US/index.html SPICE - did not match any documents.

Nothing at all for documentation.







Additional info:
I don't have a RHEL installation, but I did check my Centos6 VM host whose guests I'm trying to connect to with spicec - nothing there either.
Comment 1 Gerd Hoffmann 2011-10-17 06:11:43 EDT
man qemu | less +/spice
Comment 2 Pete Travis 2011-10-17 11:05:18 EDT
That helps a bit, sure. For what it's worth, the changelogs in /usr/share are more revealing than anything. I'm still failing with spicec, and the program itself isn't verbose enough to help me, but I think I've made that point to my satisfaction. I'm going to see about improving the fp.o documentation on this - the bug report as a feature request, I don't want it to turn into a support ticket.
Comment 3 Pete Travis 2012-06-02 15:03:22 EDT
I don't see any reason to keep this bug open. The issues I experienced at the time of reporting that had me searching for documentation were specific to my implementation, and have since been resolved. With the extraneous factors accounted for, spicec is functioning as expected.

Note You need to log in before you can comment on or make changes to this bug.