Bug 746693 - Can't login via gdm when `metacity` pkg is not installed
Summary: Can't login via gdm when `metacity` pkg is not installed
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
(Show other bugs)
Version: 16
Hardware: Unspecified Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH RejectedBlocker
Keywords:
: 729642 747161 750523 (view as bug list)
Depends On:
Blocks: F16Blocker-xfce
TreeView+ depends on / blocked
 
Reported: 2011-10-17 14:40 UTC by Adam Tkac
Modified: 2013-04-30 23:50 UTC (History)
8 users (show)

Fixed In Version: gdm-3.2.1.1-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-02 18:19:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add xfwm4 launcher to gdm (1.32 KB, patch)
2011-11-01 20:45 UTC, Michael Cronenworth
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 750397 None None None Never

Description Adam Tkac 2011-10-17 14:40:49 UTC
Description of problem:
I've just updated to the F16 and I'm not able to login via gdm when metacity
package is not installed. I don't use GNOME, I use fluxbox, so metacity wasn't
present on my fully-functional F15 machine.

Version-Release number of selected component (if applicable):
$ rpm -q gdm
gdm-3.2.0-2.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. install gdm and fluxbox pkgs, remove metacity pkg
2. boot to runlevel 5 and try to log in
3.
  
Actual results:
gdm fails to start with complains that gdm-shell is missing (I don't have it installed)

Expected results:
successful login

Additional info:
When I installed metacity package, I was able to login again.

Comment 1 Matthias Clasen 2011-10-24 21:56:38 UTC
*** Bug 747161 has been marked as a duplicate of this bug. ***

Comment 2 Matthias Clasen 2011-10-24 22:09:44 UTC
*** Bug 729642 has been marked as a duplicate of this bug. ***

Comment 3 Adam Williamson 2011-10-26 19:43:35 UTC
gdm should probably require metacity, for now at least. but why does it require a WM at all, in fallback mode? gdm never used to need one.

Comment 4 Christoph Wickert 2011-11-01 13:44:31 UTC
This is a blocker for the Xfce Spin, raising severity to urgent.

Ray, Matthias, please give some insight what causes this bug and what we are supposed to do here. We fixed bug 750397 and now we are running into this problem.

Comment 5 Christoph Wickert 2011-11-01 14:45:50 UTC
*** Bug 750523 has been marked as a duplicate of this bug. ***

Comment 6 Christoph Wickert 2011-11-01 14:47:06 UTC
As you can see from the number of duplicates this needs to be fixed in gdm. We can only fix it for the Xfce spin if if we add metacity there, but this won't help people who install Xfce from the DVD.

Comment 7 Christoph Wickert 2011-11-01 14:50:53 UTC
Setting F16Blocker since this not only affects Xfce (which is only NTH but not a blocker) but GNOME itself.

Comment 8 Adam Williamson 2011-11-01 15:44:26 UTC
This has no material impact on a default GNOME install from spin or DVD because they both contain the 'metacity' package, so this isn't really a blocker. But I'd support re-spinning Xfce one more time to fix it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 Adam Williamson 2011-11-01 19:54:44 UTC
Discussed at 2011-11-01 emergency blocker review meeting. Accepted as NTH as it breaks the non-blocker Xfce desktop.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Fedora Update System 2011-11-01 20:11:48 UTC
gdm-3.2.1.1-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gdm-3.2.1.1-6.fc16

Comment 11 Michael Cronenworth 2011-11-01 20:45:08 UTC
Created attachment 531193 [details]
add xfwm4 launcher to gdm

I've attached a simple patch that will call xfwm4 if metacity doesn't exist. It falls back to compiz, last, if both metacity and xfwm4 do not exist.

Why is the calling of window managers hard coded in GDM? I swear that back in the old days we had a "switch-desk" or similar named program that allowed you to use different window managers.

Comment 12 Bowie Owens 2011-11-01 21:58:58 UTC
If it helps, I am happy to retry the installation process. Please let me know when the fix is ready to try.

Comment 13 Fedora Update System 2011-11-02 18:19:27 UTC
gdm-3.2.1.1-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.