Bug 746918 - cpuscaling failure on v7-1-4-30 cpus don't settle to minimum frequency for On Demand test.
cpuscaling failure on v7-1-4-30 cpus don't settle to minimum frequency for On...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
6.1
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
: 750698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-18 05:34 EDT by Gregg Shick
Modified: 2011-11-08 10:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-08 10:43:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
x64 results (1.45 MB, application/octet-stream)
2011-10-18 05:34 EDT, Gregg Shick
no flags Details
x86 results (1.92 MB, application/octet-stream)
2011-10-18 05:36 EDT, Gregg Shick
no flags Details
patch changing ondemand minimum settling to warning only (705 bytes, patch)
2011-11-03 11:35 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Gregg Shick 2011-10-18 05:34:50 EDT
Created attachment 528755 [details]
x64 results

Description of problem:
Cpuscaling fails randomly with 6.1 x86/x64 and beta v7-1-4 kit.  


Version-Release number of selected component (if applicable):
6.1 x86/x64 and v7-1-4

How reproducible:
Consistenlty

Steps to Reproduce:
1. Install OS on DL360 G7 - either x86 or x64
2. Install beta kit
3. Execute cert tests.  
  
Actual results:
FAIL

Expected results:
PASS with the new kit.  

Additional info:

If possible I need someone to explain why this log fails (trying to determine what to look for).  It gives an error while testing package two, but it seems that package 1 had the exact same issues and it passed.
Comment 1 Gregg Shick 2011-10-18 05:36:29 EDT
Created attachment 528757 [details]
x86 results
Comment 2 Greg Nichols 2011-10-18 10:50:06 EDT
The error is that one cpu did not settle to minimum value at the start of the On Demand test.

cpu0 scaling_cur_freq = 1596000
cpu2 scaling_cur_freq = 2927000
Warning: cpu2 in package 0 has the value 2927000 which differs from other cpus in the package
cpu4 scaling_cur_freq = 1596000
cpu6 scaling_cur_freq = 1596000
cpu8 scaling_cur_freq = 1596000
cpu10 scaling_cur_freq = 1596000
cpu12 scaling_cur_freq = 1596000
cpu14 scaling_cur_freq = 1596000
cpu16 scaling_cur_freq = 1596000
cpu18 scaling_cur_freq = 1596000
cpu20 scaling_cur_freq = 1596000
cpu22 scaling_cur_freq = 1596000
Using cpuinfo_cur_freq
Error: Could not verify that cpu frequency has settled to the minimum value
Comment 3 Gregg Shick 2011-10-18 12:01:35 EDT
But we get the same error in package 1 and it doesn't give an Error

Single CPU On Demand Test:
-------------------------------------------------
Setting governor to ondemand
Waiting 5 seconds... done.

Checking current cpu frequency:
cpu1 cpuinfo_cur_freq = 1596000
cpu3 cpuinfo_cur_freq = 1596000
cpu5 cpuinfo_cur_freq = 1596000
cpu7 cpuinfo_cur_freq = 1596000
cpu9 cpuinfo_cur_freq = 1596000
cpu11 cpuinfo_cur_freq = 1596000
cpu13 cpuinfo_cur_freq = 1596000
cpu15 cpuinfo_cur_freq = 1596000
cpu17 cpuinfo_cur_freq = 1596000
cpu19 cpuinfo_cur_freq = 1596000
cpu21 cpuinfo_cur_freq = 1596000
cpu23 cpuinfo_cur_freq = 1596000
cpu1 scaling_cur_freq = 1596000
cpu3 scaling_cur_freq = 2927000
Warning: cpu3 in package 1 has the value 2927000 which differs from other cpus in the package
cpu5 scaling_cur_freq = 1596000
cpu7 scaling_cur_freq = 1596000
cpu9 scaling_cur_freq = 1596000
cpu11 scaling_cur_freq = 1596000
cpu13 scaling_cur_freq = 1596000
cpu15 scaling_cur_freq = 1596000
cpu17 scaling_cur_freq = 1596000
cpu19 scaling_cur_freq = 1596000
cpu21 scaling_cur_freq = 1596000
cpu23 scaling_cur_freq = 1596000
Using cpuinfo_cur_freq
Using cpu 1 to test Single CPU On Demand.
Comment 4 Greg Nichols 2011-10-18 12:45:23 EDT
Sorry, in comment 2, I missed pasting in the real source of the error:

Checking current cpu frequency:
cpu0 cpuinfo_cur_freq = 2927000
cpu2 cpuinfo_cur_freq = 2927000
cpu4 cpuinfo_cur_freq = 2927000
cpu6 cpuinfo_cur_freq = 2927000
cpu8 cpuinfo_cur_freq = 2927000
cpu10 cpuinfo_cur_freq = 2927000
cpu12 cpuinfo_cur_freq = 2927000
cpu14 cpuinfo_cur_freq = 2927000
cpu16 cpuinfo_cur_freq = 2927000
cpu18 cpuinfo_cur_freq = 2927000
cpu20 cpuinfo_cur_freq = 2927000
cpu22 cpuinfo_cur_freq = 2927000
cpu0 scaling_cur_freq = 1596000
cpu2 scaling_cur_freq = 2927000
Warning: cpu2 in package 0 has the value 2927000 which differs from other cpus in the package
cpu4 scaling_cur_freq = 1596000
cpu6 scaling_cur_freq = 1596000
cpu8 scaling_cur_freq = 1596000
cpu10 scaling_cur_freq = 1596000
cpu12 scaling_cur_freq = 1596000
cpu14 scaling_cur_freq = 1596000
cpu16 scaling_cur_freq = 1596000
cpu18 scaling_cur_freq = 1596000
cpu20 scaling_cur_freq = 1596000
cpu22 scaling_cur_freq = 1596000
Using cpuinfo_cur_freq
Error: Could not verify that cpu frequency has settled to the minimum value

In this case, cpuinfo_cur_freq (the first logged set of values) are consistent, but show the cpus are still at 2927000, which is not the minimum frequency, so the test fails.   scaling_cur_freq shows inconsistent results, but is only a warning.

The log in comment 3 only shows the inconsistency for scaling_cur_freq, which is only a warning.   cpuinfo_cur_freq shows all cpus at 1596000, so it passes.
Comment 5 Caspar Zhang 2011-11-03 04:24:16 EDT
*** Bug 750698 has been marked as a duplicate of this bug. ***
Comment 6 Greg Nichols 2011-11-03 11:35:08 EDT
Created attachment 531586 [details]
patch changing ondemand minimum settling to warning only
Comment 11 Caspar Zhang 2011-11-04 00:22:44 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In v7 1.3, cpuscaling test may fail if could not verify cpu frequency has settled to the minimum value or not in OnDemand test, this is due to inconsistency of scaling_cur_freq, and should be a warning only. This issue has been fixed in v7 1.4, now cpuscaling test regards such failure in OnDemand part as warning and the test will pass if other test requirements meet.
Comment 13 Caspar Zhang 2011-11-04 00:46:14 EDT
Deleted Technical Notes Contents.

Old Contents:
In v7 1.3, cpuscaling test may fail if could not verify cpu frequency has settled to the minimum value or not in OnDemand test, this is due to inconsistency of scaling_cur_freq, and should be a warning only. This issue has been fixed in v7 1.4, now cpuscaling test regards such failure in OnDemand part as warning and the test will pass if other test requirements meet.
Comment 15 errata-xmlrpc 2011-11-08 10:43:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html

Note You need to log in before you can comment on or make changes to this bug.