Bug 74723 - anaconda/kernel doesn't detect Intel Pro 100 adapter (eepro100) during install.
Summary: anaconda/kernel doesn't detect Intel Pro 100 adapter (eepro100) during install.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwdata (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-01 05:43 UTC by Jesse Keating
Modified: 2014-03-17 02:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-11 22:16:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Lspci output on a laptop w/ eepro100 driver. (1.16 KB, text/plain)
2002-10-01 20:22 UTC, Ali-Reza Anghaie
no flags Details
Hwconf of same lappy. (4.00 KB, text/plain)
2002-10-01 20:23 UTC, Ali-Reza Anghaie
no flags Details
LSPCI output from the machine that it didn't detect at install time. (879 bytes, text/plain)
2002-10-01 21:10 UTC, Jesse Keating
no flags Details
lspci -v of the box where eepro100 and emu10k1 were not detected until probed. (3.27 KB, text/plain)
2002-10-24 19:04 UTC, Jesse Keating
no flags Details

Description Jesse Keating 2002-10-01 05:43:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
My Intel Pro 100 NIC is not detected during install.  This causes some
interesting problems for firstboot (trying to register with RHN).  Once Red Hat
8.0 was installed, and even rebooted a few times, a manual run of "kudzu"
detected the eepro100.  Before running kduzu, I was able to modprobe eepro100
and configure my network.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.  Boot from Red Hat Linux 8.0 CD 1
2.  Install Red Hat Linux 8.0
3.  
	

Actual Results:  eepro100 is not detected, I'm never presented with options to
configure my network, no network when Red Hat Linux 8.0 is booted.

Expected Results:  NIC detected, allowed to configure, used upon boot.

Additional info:

This could be because I have my PC bios set for "pnp OS=yes".  The mainboard is
an Asus A7m266, the CPU is an Athlon T-Bird 1.33ghz/266fsb.

Comment 1 Ali-Reza Anghaie 2002-10-01 11:06:55 UTC
My 'eepro100' was detected properly on boot. What can I provide that might 
help determine the differences? Unless it was an anomoly or what-not. Cheers, 
-Ali

Comment 2 Michael Fulbright 2002-10-01 20:18:12 UTC
Could you attach the output from lspci?

Also could you attach /etc/sysconfig/hwconf on the system which the network card
works?

Comment 3 Ali-Reza Anghaie 2002-10-01 20:22:54 UTC
Created attachment 77944 [details]
Lspci output on a laptop w/ eepro100 driver.

Comment 4 Ali-Reza Anghaie 2002-10-01 20:23:33 UTC
Created attachment 77945 [details]
Hwconf of same lappy.

Comment 5 Ali-Reza Anghaie 2002-10-01 20:24:44 UTC
Attached w/ data from a lappy that uses the eepro100 drivers. I'll attach from 
the desktop that it all worked fine from (w/ eepro100) as well as soon as I'm 
done re-installing (test box for other things). Cheers, -Ali

Comment 6 Jesse Keating 2002-10-01 21:10:42 UTC
Created attachment 77984 [details]
LSPCI output from the machine that it didn't detect at install time.

Comment 7 Michael Fulbright 2002-10-24 17:57:00 UTC
Thanks I'll forward this to the hw database owner.

Comment 8 Bill Nottingham 2002-10-24 18:56:40 UTC
That's already in the DB; there's really no reason it shouldn't be detected. Can
you post the output of lspci -v?

Comment 9 Jesse Keating 2002-10-24 19:04:34 UTC
Created attachment 81967 [details]
lspci -v of the box where eepro100 and emu10k1 were not detected until probed.

Comment 10 Bill Nottingham 2002-10-24 19:25:51 UTC
Is this lspci from before or after the modules were probed and loaded?

Comment 11 Jesse Keating 2002-10-24 19:46:35 UTC
This is after.  After I modprobed emu10k1 and eepro100, then I ran kudzu and
kudzu picked them up.  Want me to rmmod those 2 modules and lspci -v again?

Comment 12 Bill Nottingham 2002-10-24 20:13:43 UTC
Hm, an lspci of a fresh bootup without them ever loaded would be best.

Comment 13 Jesse Keating 2003-11-11 22:16:24 UTC
So far this has been unreproducable for me.  Strange.  Closing bug.


Note You need to log in before you can comment on or make changes to this bug.