Bug 74725 - redhat-config-packages doesn't block magicdev from trying to mount the CD
Summary: redhat-config-packages doesn't block magicdev from trying to mount the CD
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-01 05:56 UTC by Jesse Keating
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-01 21:52:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2002-10-01 05:56:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When running redhat-config-packages, and when it asks for a CD to install from,
magicdev will pop up and ask if I want the CD to be mounted.  This is after
redhat-config-packages is already using the CD to copy rpms from.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  run redhat-config-packages
2.  select new packages to install
3.  insert CD when asked.
	

Actual Results:  redhat-config-packages will start using the CD, and a couple
seconds later, magicdev will ask if I want it to be mounted.

Expected Results:  magicdev should be disabled when redhat-config-packages asks
for the CD.

Additional info:

I only saw this in Gnome.  I currently use fluxbox instead of Gnome, and
magicdev doesn't pop up any windows into Fluxbox.

Comment 1 Jeremy Katz 2002-10-01 21:52:13 UTC
This is working properly for me here -- I stick in the CD, it gets mounted by
magicdev, but no window pops up and redhat-config-packages uses it as though it
mounted the CD itself.  

What options do you have set in the CD properties dialog?

Comment 2 Jesse Keating 2002-10-02 06:57:15 UTC
Hrm... oddly enough I'm unable to duplicate this again here.  I never touched
the CD settings, they were default.  I can't get it to ask me if I want to mount
the CD anymore, it just automagically mounts them.  How bizarre.   Since neither
you nor I can duplicate this, I suppose NOTABUG is appropriate.

/me wanders off to kick the gremlins out of his box....


Note You need to log in before you can comment on or make changes to this bug.