Bug 74749 - System Hangs On Boot during "Loading init"
System Hangs On Boot during "Loading init"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On: 68533
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 09:29 EDT by Nick Uniatowski
Modified: 2007-04-18 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 15:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output (5.46 KB, text/plain)
2002-10-07 20:43 EDT, Nick Uniatowski
no flags Details

  None (edit)
Description Nick Uniatowski 2002-10-01 09:29:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b)
Gecko/20020930 Phoenix/0.2

Description of problem:
The installer went smoothly. I chose a custom install, selected everything but
games, dns, and windows server. Upon rebooting the system froze on loading Init
after freeing unused kernel memory and mounting the root fs. I dont think the
filesystem is mounting, however no errors are listed. I booted in rescue mode
and the root fs mounted fine, so its not the partitions.

The system config is:
Processor: 1ghz Athlon TBird
Motherboard: Jabil AMD Motherboard R4 (AMD 750, consisting of the AMD 751
Irongate North bridge and the AMD 756 Viper South bridge)  w/latest bios update.
Memory: 512mb
Controller: Promise Ultra100 PCI
NIC: 3com 10/100 PCI
Sound: SB Live Value
Video: Nvidia Geforce 2 GTS
Mouse: MS Intellimouse
Keyboard: PS/2 Keyboard.

The system has 2 HDs.
Drive 1: is WinXP (hde)
Drive 2: has 2 partions.  / (hdf1)  swap (hdf2)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start machine
2.
3.
	

Additional info:

I found a site with a lot of info about the motherboard and links to additional
information:

http://bratlady.com/Jabil_Motherboard.shtml
Comment 1 redox2k 2002-10-03 00:14:18 EDT
Well, at least I'm not the only one with the problem. I've been looking forward 
to using RH Linux 8, but it always causes my computer to freeze when loading 
Init. I've used RH Linux 7.2 and 7.3 without any problems at all, but version 8 
hasn't been as easy to get up and running.

My system is an athlon 700 with 320 MB Ram, Geforce 4 MX 440, SB Audigy, and 2 
hard drives, primary with windows 98 and secondary will (hopefully) be home to 
RH Linux 8.... and all of this is neatly connected to a Jabil motherboard with 
the AMD Irongate chipset complete with the updated bios.
Coincidence?
Comment 2 Fabrice Bellet 2002-10-03 08:45:33 EDT
I also experience hang/spontaneous reboot with the kernel shipped in RHL8.0
on my Tyan K7 dual Athlon motherboard. The reboot occurs when doing a modprobe
on the agpgart module. I see the same problem with the 2.4.20-pre8-ac3 kernel too.
Previous RHL7.3 kernel was fine (kernel-smp-2.4.18-10 for athlon).
Comment 3 redox2k 2002-10-04 23:06:01 EDT
Since I'm an impatient person, I gave up with trying to get RH Linux 8.0
working, so I downloaded and installed Mandrake Linux 9.0 in hopes of getting a
working Linux OS on my computer. Setup was a breeze, but once I tried booting
into Mandrake, I had the same exact problem.... my computer hangs each and every
time when it reaches the line "INIT: version 2.83 booting" (that may not be
exactly what the line says, I'm pulling this out of memory, but I'm sure you can
recognize it). I did a quick search on the internet and found a thread on the a
Mandrake forum describing a very similar problem, in fact I'd say its probably
the same. Its at http://www.mandrakeforum.com/article.php?sid=2262

It describes a possible workaround that may help... I havent tried this myself
yet though.

Apparently, some controller/hard drive combinations can cause this problem. It
mentions the Promise Ultra100, which may explain why nicku is experiencing this.
It also mentions some Quantum Fireball hard drives. I just happen to have a
Quantum Fireball hard drive.... two of them in fact: Quantum Fireballct1 (10GB,
came with computer) and a Quantum FireballP AS (20GB, which came in a box under
the Maxtor name). My Jabil motherboard provides the controller that's hooked up
to these drives.

The post by the Promise Rep suggests that its a problem with the ide driver,
however it mentions that Redhat Linux 7.3 had the same problem, but I didnt
experience the hangs using that version with any of the 3 athlon kernels (the
original and the 2 updates) that was released by Redhat... apparently something
has changed between that version and version 8.0 that extends the problem to my
computer. Anyway, I hope this info helps, since I see that the status of this
bug hasnt changed since it was first put up as bug 68533.
Comment 4 Arjan van de Ven 2002-10-05 03:55:50 EDT
ide bugs are actually rather tricky and by far not easy to fix. I'm surprised
7.3 DOES work for you since the changes in IDE between 7.3 and 8.0 are very very
small......

Comment 5 Todd Tibbetts 2002-10-05 23:38:19 EDT
I'm having the same problem as decribed above (hang during boot at "INIT:
version 2.84 booting."

System: Gateway Select Athlon 850
Processor: 850 MHz Athlon
Motherboard: Jabil AMD Motherboard AMD 750, consisting of the AMD 751 Irongate
North bridge and the AMD 756 Viper South bridge
Controller: No "promise" controller that I know of... using the IDE built into 
the 750 chipset.
RAM: 512 Mb

I have used 7.0, 7.1, 7.2, and 7.3 on this machine without any problems 
whatsoever. Guess it's time to reinstall 7.3.
Comment 6 Nick Uniatowski 2002-10-06 18:15:53 EDT
I also had no probs with 7.1-7.3.


Quoted from the mandrake forum: 
"Promise has told the world + dog about this, but the fix hasn't made it into
Mandrake 8.2 or the cooker kernels. A shame since the setup let's you grab and
apply updates off the internet during install.

Here is an extract of a discussion between Promise, Linux-ide.org, and Alan Cox.

There is something wrong in drivers/ide/pdc202xx.c ide driver.
Andre Hedrick has merged ide stuff to 2.4.18 kernel that released for RedHat
7.3, SuSE 8.0 and Mandrake 8.2. That has a bug inside that is harmful to our
company.

First, in pdc202xx_dmaproc() function.

Our source code is:
unsigned long atapi_port =high_16+ 0x20 + (hwif->channel ? 0x04 : 0x00);

2.4.19pre8(RedHat 7.3, SuSE 8.0 and Mandrake 8.2) is:
unsigned long atapi_reg = high_16 + (hwif->channel ? 0x24 : 0x00);

The Primary channel get's a wrong address, So this causes our PDC20265/67 to not
work on the Primary channel with LBA48 drives.
Andre, I think this is your mistake, Could you please be kind enough to fix it?

Second, our PDC20262 controller does not support LBA48 with the hardware48hack
function. Please fix it in the pdc202xx_dmaproc() function also.

Third, I told Alan before.
In pdc202xx_new_tune_chipset() function.
We need to set timing only if ATA133 drives exist on both channels.
If not, we do not need to set timing here.
Please update this function also.

Fourth.
I hope we can add some more quirk drives to the pdc202xx.c list below
"QUANTUM FIREBALLP KA9.1"
"QUANTUM FIREBALLP KX13.6"
please append these.

The last.
I hope you guys could help us to notify RedHat, SuSE, Mandrake and
etc to fix this bug as soon as possible.

Thanks in advance and sincerely
Hank Yang (Promise)"
Comment 7 Arjan van de Ven 2002-10-07 05:18:30 EDT
Can you try adding "apm=off" to the kernel parameters (type "e" in the grub
screen and add it to the line with "vmlinuz") ?
Comment 8 Nick Uniatowski 2002-10-07 10:42:32 EDT
Tried apm=off and it boots!

Thanks Arjan. You da man!
Comment 9 Arjan van de Ven 2002-10-07 12:00:08 EDT
ok to narrow it down more:
is apm=idle_threshold=100 
as option enough to fix it?
Either way I'd like to get dmidecode (a program that's part of the kernel-utils
package) of your machine so that I can add it to the "don't do THIS on it"
Comment 10 redox2k 2002-10-07 16:02:32 EDT
Nice, now Mandrake is able to boot, with the apm=off and the 
apm=idle_threshold=100 arguments. Thanks alot arjan! I'll email you my 
dmidecode output as soon as I finish this post. Now all I have to do is 
reinstall Redhat Linux 8.0 :)
Comment 11 Nick Uniatowski 2002-10-07 20:43:51 EDT
Created attachment 79264 [details]
dmidecode output
Comment 12 Nick Uniatowski 2002-10-07 20:45:03 EDT
The apm=idle_threshold=100 arguement worked fine for me as well.
You may want to close bug 68533 as well.

Thanks again!
Comment 13 Todd Tibbetts 2002-10-07 22:54:24 EDT
The apm=idle_threshold=100 fixed my problem also.  Thanks for your prompt   
attention to this.  I would attach my dmidecode output as well if it weren't  
*completely* identical (aside from serial numbers and customer code)to the 
output posted by nicku.   
 
Nice system ya got there Nick.  :)  
 
By the way, anyone mind giving me a two line explaination as to what this fix 
did (besides make my computer boot again, heh)?
Comment 14 Arjan van de Ven 2002-10-08 04:32:11 EDT
the kernel in 8.0 does APM bios calls when it's idle. The intent of this is to
save power (since then the APM bios can do things to save power, as most laptops
do). For most "desktop" bioses this call is just a "do nothing", however it
seems your machine has a bios that actually gets upset. The "idle_threshold" is,
roughly, the percentage of idle time needed for the kernel to start doing these
calls, where "100" has a special meaning, eg "never".
Comment 15 Chris 2003-12-01 17:09:57 EST
   I had the same problem after two weeks of using linux. I rebooted 
the system for a maintenance and never started up again. It freezes 
after:
 INIT:version 2.84 booting.

   I installed the same version with kernel 2.4.20-20.9 on another 
HDD and it works fine! I tried "apm=off" but it freezes again saying:
Kernel panic: No init found. Try passing init= option to kernel.
I´m running athlon XP 2000, 256 MBram.

Note You need to log in before you can comment on or make changes to this bug.