Bug 747772 - BugZilla install fails. checksetup.pl "Creating contrib/.htaccess... No such file or directory at Bugzilla/Install/Filesystem.pm line 485."
Summary: BugZilla install fails. checksetup.pl "Creating contrib/.htaccess... No such ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bugzilla   
(Show other bugs)
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-21 02:46 UTC by Bill McGonigle
Modified: 2011-12-30 20:05 UTC (History)
7 users (show)

Fixed In Version: bugzilla-3.4.12-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 610198
Environment:
Last Closed: 2011-12-30 20:05:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill McGonigle 2011-10-21 02:46:38 UTC
Cloning as this exists in EPEL6.

Installing bugzilla-contrib is a workaround.  I'm fine with that, but dragging in ruby for this is sorta meh.

+++ This bug was initially created as a clone of Bug #610198 +++

Description of problem:

checksetup.pl fails:
"Creating contrib/.htaccess...
No such file or directory at Bugzilla/Install/Filesystem.pm line 485."

Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1. remove previous failed install of bugzilla
2. create new database for bugzilla (note:  I'm not using "bugs")
3. "yum install bugzilla" with db info in /etc/bugzilla/localconfig
  
Actual results:


Expected results:

bugzilla installs

Additional info:

the install of bugzilla attempts to connect to the DB, and acts surprised that it can't; "rpm -e bugzilla" left the "/etc/bugzilla/localconfig" file so I just filled it in.  Recommend making the error a little more meaningful, since it might confuse people who are just installing the package.  No mention of running checksetup.pl is mentioned, for instance.

Creating the contrib directory caused the install to just hang; commenting out the connect info in /etc/bugzilla/localconfig and then installing caused it to complete the install.  At that point I set the connect info again, ran checksetup.pl, and it worked fine.

Which is to say, the contrib directory (/usr/share/bugzilla/contrib) should be created by the package.

--- Additional comment from brianlamere@gmail.com on 2010-07-01 14:55:43 EDT ---

note that due to the fact that the install hangs when the contrib directory exists, I can't think of a way that the install would actually be successful if it runs checksetup.pl?  I'd recommend just displaying text at the end of the package install that tells the user to run the script.

I imagine that the "hanging" was really the checksetup.pl script prompting me for an admin email, but since I don't get all of stdout during a yum install, I wasn't seeing it.  This is the reason I suggest just not running checksetup.pl in the post-install section (assuming) of the rpm at all; just have the user run it after.

--- Additional comment from ondrejj@salstar.sk on 2010-07-06 02:00:46 EDT ---

Same problem from cron, when yum-cron updated bugzilla to bugzilla-3.4.7-1.fc12.noarch.

No such file or directory at Bugzilla/Install/Filesystem.pm line 485, <DATA>
line 228.

Although it's present in rpm package, this error was displayed. Is it possible, that it was displayed before file was moved?

--- Additional comment from emmanuel.seyman@club-internet.fr on 2010-08-18 17:33:09 EDT ---

Taking.

--- Additional comment from updates@fedoraproject.org on 2010-08-18 18:20:50 EDT ---

bugzilla-3.6.2-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/bugzilla-3.6.2-1.fc14

--- Additional comment from updates@fedoraproject.org on 2010-08-18 18:24:10 EDT ---

bugzilla-3.4.8-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bugzilla-3.4.8-2.fc13

--- Additional comment from updates@fedoraproject.org on 2010-08-18 18:24:28 EDT ---

bugzilla-3.4.8-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/bugzilla-3.4.8-1.fc12

--- Additional comment from updates@fedoraproject.org on 2010-08-19 21:29:34 EDT ---

bugzilla-3.4.8-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bugzilla'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bugzilla-3.4.8-1.fc12

--- Additional comment from updates@fedoraproject.org on 2010-08-26 23:07:09 EDT ---

bugzilla-3.6.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-08-27 02:51:53 EDT ---

bugzilla-3.4.8-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-08-27 02:54:53 EDT ---

bugzilla-3.4.8-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from mjd+redhat@afork.com on 2011-04-23 00:18:28 EDT ---

I am still having this problem on Fedora ARM F13 beta.  Bugzilla in that release is 3.4.5, so it doesn't have this fix.

For anyone in this situation, a workaround is:

  mkdir /usr/share/bugzilla/contrib

Comment 1 Fedora Update System 2011-10-24 09:26:12 UTC
bugzilla-3.4.11-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-3863

Comment 2 Fedora Update System 2011-11-10 07:30:43 UTC
Package bugzilla-3.4.12-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing bugzilla-3.4.12-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-3863
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2011-12-30 20:05:03 UTC
bugzilla-3.4.12-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.