Bug 748031 - Latest gtk2 update breaks lazarus applications
Summary: Latest gtk2 update breaks lazarus applications
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 16
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Joost van der Sluis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-21 18:59 UTC by Heiko Adams
Modified: 2012-05-12 20:25 UTC (History)
3 users (show)

(edit)
Clone Of:
: 748037 (view as bug list)
(edit)
Last Closed: 2012-05-12 20:25:33 UTC


Attachments (Terms of Use)

Description Heiko Adams 2011-10-21 18:59:54 UTC
Description of problem:
Since that latest update of gtk2 applications created with lazarus run into an exception on close.

Version-Release number of selected component (if applicable):
gtk2-2.24.7-1.fc16.i686
lazarus-0.9.30-1.fc16.i686
fpc-2.4.2-2.fc15.i686
fpc-src-2.4.2-2.fc15.i686

How reproducible:
allways

Steps to Reproduce:
1. create a new application
2. start the application from terminal
3. close the application
  
Actual results:
The following error-message is raised:

(bewerbungen:17621): Gtk-CRITICAL **: IA__gtk_widget_unrealize: assertion `GTK_IS_WIDGET (widget)' failed

(bewerbungen:17621): Gtk-CRITICAL **: IA__gtk_widget_is_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
TApplication.HandleException Access violation
  Stack trace:
  $4F65EDD8
exception at 4F65EDD8:
Access violation.
**
GLib-GObject:ERROR:gsignal.c:711:emission_pop: code should not be reached
Abgebrochen

Expected results:
The application should be closed without any exception

Additional info:
My application sourcecode hasn't been changed since at last one week so this can only be caused by the latest gtk2 update

Comment 1 Heiko Adams 2011-10-21 19:01:59 UTC
When running the application inside of lazarus ide the error is caught at line 4727 of gtk2proc.inc

Comment 2 Heiko Adams 2011-11-05 11:23:59 UTC
Fixed with gtk2-2.24.7-3


Note You need to log in before you can comment on or make changes to this bug.