Bug 748215 - coreutils requires pam >= 1.1.3-7
coreutils requires pam >= 1.1.3-7
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-10-23 01:54 EDT by Bruce Jerrick
Modified: 2011-10-24 10:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-10-24 10:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2011-10-23 01:54:11 EDT
Description of problem:
The "Requires: pam" of coreutils is inadequate -- /etc/pam.d/su does an
 'include' of postlogin, but /etc/pam.d/postlogin did not exist until
 pam-1.1.3-7 .
Without /etc/pam.d/postlogin, /bin/su will fail:

  su: cannot not open session: Permission denied

with an error message in /var/log/secure:

  ... su: PAM _pam_load_conf_file: unable to open /etc/pam.d/postlogin

So the requires line in th spec file should be:
  Requires: pam >= 1.1.3-7

Version-Release number of selected component (if applicable):
(Note: Same problem exists in util-linux-2.20-1.fc16.i686; a separate
 report has been filed against util-linux .)

This is not likely to happen on a standard spin.  And during OS install,
/etc/pam.d/postlogin is replaced by a symlink to a generated postlogin-ac .
But by examining the following, it is apparent that coreutils really does
need postlogin, and that postlogin first appeared in pam-1.1.3-7:

  $ grep postlogin /etc/pam.d/su
  $ rpm -q --changelog pam-1.1.4-4.fc16 | grep -B1 postlogin
  $ rpmls pam-1.1.4-4.fc16 | grep postlogin
Comment 1 Ondrej Vasik 2011-10-23 06:30:30 EDT
Just to be sure ... as you mention "This is not likely to happen on a standard spin.", you don't expect F16 primary arch update just for this - so just commit&build in F16&Rawhide with fixed requirements should be fine, right?
Comment 2 Ondrej Vasik 2011-10-24 10:54:30 EDT
Anyway, thanks, versioned requires added in coreutils-8.12-4.fc16 and coreutils -8.14-3.fc17, closing RAWHIDE. 
If you think that F16 update in bodhi is required, feel free to write it here, I'll do it - but I don't think it makes sense just for fixing requires (which are usually ok, if you have up2date packages).

Note You need to log in before you can comment on or make changes to this bug.