Bug 748232 - missing BASIC library dialogs on startup
missing BASIC library dialogs on startup
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-23 09:20 EDT by Pavel Alexeev
Modified: 2012-09-25 08:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 04:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
get backtrace (239 bytes, text/plain)
2011-10-27 09:01 EDT, David Tardon
no flags Details
Requestet backtrace (7.25 KB, text/plain)
2011-10-30 09:33 EDT, Pavel Alexeev
no flags Details
Please. Off course you need delete "DEL" from name (197.05 KB, application/x-xz)
2012-01-28 12:14 EST, Pavel Alexeev
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 47953 None None None 2012-09-25 08:05:18 EDT

  None (edit)
Description Pavel Alexeev 2011-10-23 09:20:13 EDT
Description of problem:
Each time I start LibreOffice Writer I got modal windows with next errors:
Error loading BASIC of document
file:///home/pasha/.libreoffice/3/user/basic/dialog.xlc/:
General Error.
General input/output error.

I press Ok, then:
Error loading BASIC of document
file:///home/pasha/.libreoffice/3/user/basic/dialog.xli/:
General Error.
General input/output error.

Only after press OK there Writer starts.

This mentioned files really are absent:
$ LANG=C ls /home/pasha/.libreoffice/3/user/basic/dialog.*
ls: cannot access /home/pasha/.libreoffice/3/user/basic/dialog.*: No such file or directory

Delete of /home/pasha/.libreoffice - does not helps - directory recreated, but error appeared again.

Version-Release number of selected component (if applicable):
$ rpm -qa 'libreoffice*'
libreoffice-langpack-ru-3.4.3.2-11.fc16.x86_64
libreoffice-presenter-screen-3.4.3.2-11.fc16.x86_64
libreoffice-calc-3.4.3.2-11.fc16.x86_64
libreoffice-kde-3.4.3.2-11.fc16.x86_64
libreoffice-graphicfilter-3.4.3.2-11.fc16.x86_64
libreoffice-writer-3.4.3.2-11.fc16.x86_64
libreoffice-core-3.4.3.2-11.fc16.x86_64
libreoffice-langpack-en-3.4.3.2-11.fc16.x86_64
libreoffice-ure-3.4.3.2-11.fc16.x86_64
libreoffice-pdfimport-3.4.3.2-11.fc16.x86_64
libreoffice-xsltfilter-3.4.3.2-11.fc16.x86_64
libreoffice-math-3.4.3.2-11.fc16.x86_64
libreoffice-draw-3.4.3.2-11.fc16.x86_64
libreoffice-impress-3.4.3.2-11.fc16.x86_64
libreoffice-opensymbol-fonts-3.4.3.2-11.fc16.noarch

How reproducible:
Always.
Comment 1 David Tardon 2011-10-24 03:16:57 EDT
It works fine here. The ~/.libreoffice/3/user/basic dir has the following content (which is recreated automatically if I remove ~/.libreoffice):

$ ls -F1 ~/.libreoffice/3/user/basic
dialog.xlc
script.xlc
Standard/

Does ~/.openoffice.org dir exist? If yes, could you move it away to rule out possible migration problem?
Comment 2 Pavel Alexeev 2011-10-24 05:54:44 EDT
$ ls -F1 ~/.libreoffice/3/user/basic
script.xlc
Standard/

So, I think problem what by some reason directory file:///home/pasha/.libreoffice/3/user/basic/dialog.xlc/ (note trailing slash) tried be opened instead of file.

$ LANG=C ls -F1 ~/.openoffice*
ls: cannot access /home/pasha/.openoffice*: No such file or directory
Comment 3 David Tardon 2011-10-27 08:51:27 EDT
(In reply to comment #2)
> $ ls -F1 ~/.libreoffice/3/user/basic
> script.xlc
> Standard/
> 
> So, I think problem what by some reason directory
> file:///home/pasha/.libreoffice/3/user/basic/dialog.xlc/ (note trailing slash)
> tried be opened instead of file.

This is a red herring: the trailing slash is stripped by fileaccess::FileContentIdentifier (but we cannot rely on that, so it is a bug), so it tries to open the right file.
Comment 4 David Tardon 2011-10-27 09:01:08 EDT
Created attachment 530480 [details]
get backtrace

The file should exist when basic::SfxLibraryContainer::init is called. Maybe it is called too soon for some reason? Could you install gdb and libreoffice-debuginfo, get the attached gdb script and run

gdb -nx -x bt.gdb --args /usr/lib64/libreoffice/program/soffice.bin --writer

? Then attach /tmp/basic-init.bt there.
Comment 5 Pavel Alexeev 2011-10-30 04:59:46 EDT
Unfortunately not at this time - now debuginfo dependency consolidation broken:
# LANG=C yum install libreoffice-debuginfo gdb
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Setting up Install Process
Package gdb-7.3.50.20110722-9.fc16.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package libreoffice-debuginfo.x86_64 1:3.4.3.2-11.fc16 will be installed
--> Processing Dependency: libreoffice-gdb-debug-support = 1:3.4.3.2-11.fc16 for package: 1:libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64
--> Processing Dependency: libreoffice-core = 1:3.4.3.2-11.fc16 for package: 1:libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64
--> Running transaction check
---> Package libreoffice-debuginfo.x86_64 1:3.4.3.2-11.fc16 will be installed
--> Processing Dependency: libreoffice-core = 1:3.4.3.2-11.fc16 for package: 1:libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64
---> Package libreoffice-gdb-debug-support.x86_64 1:3.4.3.2-11.fc16 will be installed
--> Finished Dependency Resolution
Error: Package: 1:libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64 (fedora-debuginfo)
           Requires: libreoffice-core = 1:3.4.3.2-11.fc16
           Installed: 1:libreoffice-core-3.4.3.2-14.fc16.x86_64 (@updates-testing)
               libreoffice-core = 1:3.4.3.2-14.fc16
           Available: 1:libreoffice-core-3.4.3.2-11.fc16.x86_64 (fedora)
               libreoffice-core = 1:3.4.3.2-11.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Off course I try latter
Comment 6 David Tardon 2011-10-30 05:18:29 EDT
(In reply to comment #5)
> Unfortunately not at this time - now debuginfo dependency consolidation broken:
> Error: Package: 1:libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64
> (fedora-debuginfo)
>            Requires: libreoffice-core = 1:3.4.3.2-11.fc16
>            Installed: 1:libreoffice-core-3.4.3.2-14.fc16.x86_64
> (@updates-testing)
>                libreoffice-core = 1:3.4.3.2-14.fc16
>            Available: 1:libreoffice-core-3.4.3.2-11.fc16.x86_64 (fedora)
>                libreoffice-core = 1:3.4.3.2-11.fc16

It is not broken; you just do not have the necessary repositories enabled. Try

yum install --enablerepo=updates-testing* libreoffice-debuginfo
Comment 7 Pavel Alexeev 2011-10-30 09:33:32 EDT
Created attachment 530829 [details]
Requestet backtrace

Oh sorry. I'm beleave I have enabled updates-testing repository... But it obvousely do not related to updates-testing-debuginfo too. Enabled by default now.

Result file attached. But Writer does not start at all.
I hope it usefull.
Comment 8 Caolan McNamara 2011-11-01 06:12:43 EDT
I wonder if this is perhaps a migration problem from an older install, shouldn't we be looking in .config/libreoffice in 3.4.3.3 not .libreoffice ?
Comment 9 David Tardon 2011-11-01 08:07:36 EDT
(In reply to comment #7)
> Result file attached. But Writer does not start at all.
> I hope it usefull.

Unfortunately, it is not :( It looks all right, so the problem must be elsewhere. Do you have sufficient rights to create the file at all? E.g., does

touch ~/.libreoffice/3/user/basic/script.xlc

work? I would like to see the output of

stat ~/.libreoffice/3/user/basic

in any case.
Comment 10 Pavel Alexeev 2011-11-01 13:11:13 EDT
.config/libreoffice does not exists:

LANG=C ls .config/libreoffice
ls: cannot access .config/libreoffice: No such file or directory

(In reply to comment #9)
> (In reply to comment #7)
> touch ~/.libreoffice/3/user/basic/script.xlc
> 
> work?
yes

> I would like to see the output of
> 
> stat ~/.libreoffice/3/user/basic
> 
> in any case.
Please:
$ LANG=C stat ~/.libreoffice/3/user/basic
  File: `/home/pasha/.libreoffice/3/user/basic'
  Size: 4096            Blocks: 8          IO Block: 4096   directory
Device: 809h/2057d      Inode: 6425692     Links: 3
Access: (0775/drwxrwxr-x)  Uid: ( 1000/   pasha)   Gid: ( 1000/   pasha)
Access: 2011-10-23 17:19:23.148257594 +0400
Modify: 2011-10-17 11:12:53.939683942 +0400
Change: 2011-10-17 11:12:53.939683942 +0400
 Birth: -
Comment 11 Caolan McNamara 2011-11-08 06:22:37 EST
All works fine here for me on F-16. *anything* unusual about your setup which might be relevant, home dir mounted in any strange way, non UTF-8 locale ?
Comment 12 Pavel Alexeev 2011-11-13 07:26:47 EST
Hello, Caolan.

I have not found anything anusual. Home mounted even without LVM:
$ mount | grep /home
/dev/sda9 on /home type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)

Locale is UTF:
$ locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

On C locale it also reproduced as you can see before.
Comment 13 Caolan McNamara 2011-11-14 05:49:37 EST
You have two bugs opened, this one and bug 750170 both of which no-one else can reproduce. Having two such bugs is really odd.
Comment 14 Pavel Alexeev 2011-11-14 06:28:27 EST
May be... And what? What I can provide or do to help fix it?
Comment 15 Caolan McNamara 2012-01-10 09:35:56 EST
I don't know :-( Can't reproduce this problem.
Comment 16 Pavel Alexeev 2012-01-10 10:10:05 EST
Please, can you help me? I ready provide any requested info. It is 100% reproduced and very annoying.
Comment 17 reubendb 2012-01-11 15:40:37 EST
I get exactly the same issue here as described. This is on a clean installation of Fedora 16 on a new machine (HD was reformatted from scratch), new home directory, so no possible migration conflict. 

The only thing I remember that may be relevant is that the _first time_ I used LibreOffice was to open some .docx or even .pptx documents from a link on the web (automatically opened by Firefox). That's where I started getting the error. Then even when I just start LibreOffice without opening any document, I kept getting the error.

Fortunately the remedy is simple for me since I barely have anything yet on this machine: "rm -rf ~/.libreoffice".
Comment 18 Pavel Alexeev 2012-01-12 09:16:02 EST
So, I think it is reproduced not only on my machine. Reopening.

And I also may confirm what removing (renaming) ~/.libreoffice help solve it.
Do you want a copy of this directory for investigating (I hope there should not be any private things)?
Comment 19 David Tardon 2012-01-24 02:47:39 EST
dtardon->pahan: Yes, that might help. Seems we are out of ideas anyway...
Comment 20 Pavel Alexeev 2012-01-28 12:14:37 EST
Created attachment 558069 [details]
Please. Off course you need delete "DEL" from name
Comment 21 Michael Stahl 2012-03-01 15:22:20 EST
somebody committed this to LO master, which would silently ignore the missing .xlc files at least (but you still get an error from line 1680 if the .xlc file exists and lists an .xlb file that does not exist):

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1543f1ec6deba898f71b04d242af8bed74dcd8d6

not sure if that is the right approach though...

the .xlc files get re-created if you open the Basic script organizer.

(i've got a user profile that has somehow managed to develop a similar problem.
it was accessed variously by LO master, 3.5, 3.4 builds, often crashing, and lives on /tmp so probably has files deleted from it at random as well...)
Comment 22 Stephan Bergmann 2012-03-01 17:00:14 EST
Btw, this mystery appears to be with the OpenOffice.org code base for a long time already, cf. <https://issues.apache.org/ooo/show_bug.cgi?id=59890> "[meta] Error loading basic of document."
Comment 23 Caolan McNamara 2012-03-27 05:47:00 EDT
grr, this happened to *me* now once as well, but no idea how it happened or how to reproduce it either :-)
Comment 24 Stephan Bergmann 2012-09-25 04:52:45 EDT
This is a duplicate of upstream <https://bugs.freedesktop.org/show_bug.cgi?id=47953> "Error messages when opening LibreOffice."

Note You need to log in before you can comment on or make changes to this bug.