Bug 748485 - Sunbird cannot be installed
Summary: Sunbird cannot be installed
Keywords:
Status: CLOSED DUPLICATE of bug 684377
Alias: None
Product: Fedora
Classification: Fedora
Component: sunbird
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-24 15:19 UTC by Zoltan Boszormenyi
Modified: 2011-11-10 20:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-10 20:36:25 UTC
Type: ---


Attachments (Terms of Use)

Description Zoltan Boszormenyi 2011-10-24 15:19:51 UTC
Description of problem:

I don't have evolution installed, I don't like it.
I use Thunderbird and wanted to use the Mozilla
calendar application as well on my desktop.
But Sunbird cannot be installed because of a
dependency problem.

# yum install sunbird
...
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package sunbird.x86_64 0:1.0-0.33.b2pre.fc15 will be installed
--> Processing Dependency: libnotify.so.1()(64bit) for package: sunbird-1.0-0.33.b2pre.fc15.x86_64
--> Finished Dependency Resolution
Error: Package: sunbird-1.0-0.33.b2pre.fc15.x86_64 (fedora)
           Requires: libnotify.so.1()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

# ls /usr/lib64/libnotify*
/usr/lib64/libnotify.so  /usr/lib64/libnotify.so.4  /usr/lib64/libnotify.so.4.0.0
# rpm -q libnotify
libnotify-0.7.3-1.fc15.x86_64

libnotify seems to have changed its library version
since Sunbird was compiled.

Version-Release number of selected component (if applicable):

# yum info sunbird
...
Available Packages
Name        : sunbird
Arch        : x86_64
Version     : 1.0
Release     : 0.33.b2pre.fc15
Size        : 17 M
Repo        : fedora
Summary     : Calendar application built upon Mozilla toolkit
URL         : http://www.mozilla.org/projects/calendar/sunbird/
License     : MPLv1.1 or GPLv2+ or LGPLv2+
Description : Mozilla Sunbird is a cross-platform calendar application, built upon
            : Mozilla Toolkit. It brings Mozilla-style ease-of-use to your
            : calendar, without tying you to a particular storage solution.


How reproducible:

Always.

Steps to Reproduce:
1. Install Fedora 15 without evolution (in my case I upgraded from Fedora 14 that was tailored to my needs)
2. Try to install sunbird.
3. Get disappointed.

Actual results:

Cannot install sunbird.

Expected results:

Sunbird can be installed and work, also announces itself in the gnome settings as a calender application.

Additional info: There is a light but cold autumn breeze outside. My russian blue cat sleeps on my bed because he doesn't want to get cold. :-)

Comment 1 David Juran 2011-11-10 20:36:25 UTC

*** This bug has been marked as a duplicate of bug 684377 ***


Note You need to log in before you can comment on or make changes to this bug.