Bug 748496 - Launching a deployable with inter-assembly parameter references fails
Summary: Launching a deployable with inter-assembly parameter references fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Greg Blomquist
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-24 15:42 UTC by Greg Blomquist
Modified: 2012-01-25 17:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-25 17:05:10 UTC


Attachments (Terms of Use)

Description Greg Blomquist 2011-10-24 15:42:45 UTC
Description of problem:

When trying to launch a deployable with inter-assembly parameter references results in the error message:

  undefined local variable or method `reference_service' for #<ParameterXML:0x7fd494b831c8>

Comment 1 Greg Blomquist 2011-10-25 21:05:08 UTC
Using this test deployable: http://file.rdu.redhat.com/~gblomqui/deployables/bz748496.xml

Patch submitted:
https://fedorahosted.org/pipermail/aeolus-devel/2011-October/006094.html

Before the submitted patch, the user encounters the following error when launching:

undefined local variable or method `reference_service' for
#<ParameterXML:0x7fd494b831c8>

Now, the deployable launches successfully.

Comment 2 Greg Blomquist 2012-01-25 17:05:10 UTC
Since this patch is several months old, the code that this patch affected has actually been obsoleted.  Closing, not a bug.


Note You need to log in before you can comment on or make changes to this bug.