Bug 74855 - Disk Druid hangs when click on graphic partition view
Disk Druid hangs when click on graphic partition view
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 06:36 EDT by Sxren Nielsen
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-13 16:27:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sxren Nielsen 2002-10-02 06:36:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; da-DK; rv:1.0.1) Gecko/20020830

Description of problem:
When clicking in the graphic partition overview box in top right part of the
Disk Druid display, the installer freeze.
It is possible to use Disk Druid by only using the tree partition overview below.
The partitions are shown correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start DiskDruid
2. Click in graphic partition view
	

Actual Results:  Installer / Disk Druid freeze.
X still running (Can move mousepointer, Alt+Ctrl+F? works).

Expected Results:  A partition should be selected.

Additional info:

I have 2 harddisks at a Promise Ultra100tx2 as hde and hdg.
Comment 1 Michael Fulbright 2002-10-02 12:04:48 EDT
Could you please list the partition tables for both drives?

This was a problem during the betas but I thought I'd fixed it.
Comment 2 Sxren Nielsen 2002-10-02 18:45:51 EDT
Disk /dev/hde: 255 heads, 63 sectors, 3737 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hde1   *         1       784   6297448+   c  Win95 FAT32 (LBA)
/dev/hde2           785      2074  10361925    5  Extended
/dev/hde4          2075      3737  13358047+  83  Linux
/dev/hde5           785      2074  10361893+  83  Linux


Disk /dev/hdg: 255 heads, 63 sectors, 3737 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdg1             1        33    265041   82  Linux swap
/dev/hdg2   *        34       686   5245222+  83  Linux
/dev/hdg3           687      3737  24507157+  83  Linux
Comment 3 Michael Fulbright 2002-11-01 12:53:34 EST
Thanks.
Comment 4 Michael Fulbright 2003-03-13 16:27:02 EST
I have been unable to reproduce this issue.
Comment 5 Brian Dickman 2003-04-03 16:46:21 EST
Another sighting of this bug.  Here's the parition tables:

-/bin/sh-2.05b# fdisk -l /dev/hda                                               
                                                                                
Disk /dev/hda: 255 heads, 63 sectors, 4998 cylinders                            
Units = cylinders of 16065 * 512 bytes                                          
                                                                                
   Device Boot    Start       End    Blocks   Id  System                        
/dev/hda1   *         1       261   2096451    6  FAT16                         
/dev/hda2           262       522   2096482+   5  Extended                      
/dev/hda5           262       522   2096451    7  HPFS/NTFS                     
-/bin/sh-2.05b# fdisk -l /dev/hdb                                               
                                                                                
Disk /dev/hdb: 255 heads, 63 sectors, 4998 cylinders                            
Units = cylinders of 16065 * 512 bytes                                          
                                                                                
   Device Boot    Start       End    Blocks   Id  System                        
/dev/hdb1   *         1      1020   8193118+   b  Win95 FAT32

Note You need to log in before you can comment on or make changes to this bug.