Bug 74868 - up2date fails after upgrading RPM to 4.1
up2date fails after upgrading RPM to 4.1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 09:24 EDT by Andre
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 12:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full SRPM build output (846 bytes, application/bzip2)
2002-10-02 09:26 EDT, Andre
no flags Details

  None (edit)
Description Andre 2002-10-02 09:24:24 EDT
Description of Problem:
After upgrading RPM to 4.1, up2date fails (it doesn't even establish a 
connection, it seems Python code bombs)

Version-Release number of selected component (if applicable):
2.7.61-7.x.1

How Reproducible:
Always

Steps to Reproduce:
1. just run up2date
2. 
3. 

Actual Results:
Traceback (innermost last):
  File "/usr/sbin/up2date", line 15, in ?
    from up2date_client import up2date
  File "/usr/share/rhn/up2date_client/up2date.py", line 731, in ?
    rpm_version = getRpmVersion()
  File "/usr/share/rhn/up2date_client/up2date.py", line 722, in 
getRpmVersion
    db = openrpmdb()
  File "/usr/share/rhn/up2date_client/up2date.py", line 715, in openrpmdb
    db = rpm.opendb(option)
AttributeError: opendb


Expected Results:
successful connection

Additional Information:
RPM packages installed:
rpm-4.1-7x
rpm-devel-4.1-7x
rpm-build-4.1-7x
rpm-python-4.1-7x

DB4 is *not* installed. DB3 packages are:
db3-3.1.17-7
db3-utils-3.1.17-7
db3-devel-3.1.17-7

Python packages installed:
pythonlib-1.28-1
python-popt-0.8.8-7.x.1
python-1.5.2-30
python-xmlrpc-1.5.1-7.x.3
python-devel-1.5.2-30

I tried rebuilding up2date from up2date-2.7.86-7.x.3.src.rpm, but it fails 
with:

[snip]
gcc -o rhnsd rhnsd.o
make[1]: Entering directory `/home/costa/redhat/BUILD/up2date-2.7.86/man'
Makefile:44: *** target pattern contains no `%'.  Stop.
make[1]: Leaving directory `/home/costa/redhat/BUILD/up2date-2.7.86/man'
make: *** [all] Error 1
error: Bad exit status from /var/tmp/rpm/rpm-tmp.36461 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm/rpm-tmp.36461 (%build)

(full build output attached)
Comment 1 Andre 2002-10-02 09:26:40 EDT
Created attachment 78065 [details]
full SRPM build output
Comment 2 Andre 2002-10-11 09:54:54 EDT
Hi,
still no joy... =( just upgraded up2date to 2.8.39, but the errors are 
pretty much the same:

up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 17, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 8, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 11, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 15, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 274, in ?
    rpm_version = getRpmVersion()
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 265, in 
getRpmVersion
    db = openrpmdb()
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 50, in openrpmdb
    db = rpm.opendb(option)
AttributeError: opendb

It looks like it's running into trouble trying to interact with rpmdb. 
Should I upgrade to DB4?

TIA

Andre
Comment 3 Adrian Likins 2002-10-11 12:14:41 EDT
Is this on a 7.x box?

rpm-4.1 is currently unsupported on anything but Red Hat Linux 8.0.

There are no versions of up2date available that support rpm-4.1 on
6.2-7.3.
Comment 4 Andre 2002-10-14 11:51:21 EDT
Hi,

you were right, I just downgraded to 4.0.4 and up2date worked again. IMHO you 
should consider making it explicit on www.rpm.org that, although being the 
latest stable version, 4.1 is unsupported on RH 7.x.

Thks for the help.

Best,

Andre

Note You need to log in before you can comment on or make changes to this bug.