Bug 74871 - Radeon 7000 PCI
Radeon 7000 PCI
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82776
  Show dependency treegraph
 
Reported: 2002-10-02 09:45 EDT by adler
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-29 09:36:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log output when Radeon is properly detected (17.76 KB, patch)
2002-10-02 09:47 EDT, adler
no flags Details | Diff
X log output when Radeon is not properly detected (21.24 KB, patch)
2002-10-02 09:48 EDT, adler
no flags Details | Diff
XFree86 config file which exposes this bug (4.38 KB, patch)
2002-10-04 08:52 EDT, adler
no flags Details | Diff
lspci -nv (3.37 KB, patch)
2002-10-04 08:53 EDT, adler
no flags Details | Diff

  None (edit)
Description adler 2002-10-02 09:45:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
XFree86 Radeon server fails to operate the Radeon 7000 PCI properly

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run X
2.
3.
	

Actual Results:  XFree86 server fails to properly initialize the Radeon 7000 PCI
card

Additional info:

After a fresh reboot, the XFree86 server does properly initalize the Radeon 7000
PCI card and it works properly. When I kill the X server and restart it, it
fails to initialize it properly. The log from the X server reports that it fails
to read the V_BIOS.

(EE) RADEON(1): Cannot read V_BIOS

Furthermore, it tries some very funcky stuff to access the card...

> (WW) RADEON(1): Video BIOS not detected in PCI space!
> (WW) RADEON(1): Attempting to read Video BIOS from legacy ISA space!

I've attached 2 versions of the X log output. The first is the output when I
start X just after a fresh reboot and it works ok, the second is after I startup
X the second time.
Comment 1 adler 2002-10-02 09:47:13 EDT
Created attachment 78084 [details]
X log output when Radeon is properly detected
Comment 2 adler 2002-10-02 09:48:01 EDT
Created attachment 78085 [details]
X log output when Radeon is not properly detected
Comment 3 adler 2002-10-02 09:49:21 EDT
Another comment to this bug. Do a diff on the two log files to find some
interesting info on how the Radeon is failing.
Comment 4 Mike A. Harris 2002-10-03 23:44:02 EDT
Attach "lspci -vn" please

Also attach both working/nonworking config files, and indicate 
which is which.
Comment 5 adler 2002-10-04 08:52:29 EDT
Created attachment 78604 [details]
XFree86 config file which exposes this bug
Comment 6 adler 2002-10-04 08:53:19 EDT
Created attachment 78605 [details]
lspci -nv
Comment 7 adler 2002-10-04 08:55:19 EDT
I only used one XF86Config file. The problem is this. When I reboot the
system, the card works fine the first time you start X. It's on the second
time and every other time you run X that it fails. It looks to me like the
Xserver is not properly initializing the card.
Comment 8 Need Real Name 2002-10-16 16:24:05 EDT
I see the same problem on a Radeon 7500.  After the initial upgrade from 7.3,
it worked ok, but on the next reboot (from power on), the screen does not
properly initialize.  Also, Vterm switching with Ctrl-F1 does not work and the
machine has to be hard reset.  It generally takes two or three times before the
screen works.  On the screen has worked, subsequent reboots work ok as long as
the system has not been powered off.

The driver has obviously been upgraded since the fix in 7.3 since Vterm
switching is much faster and smoother than in 7.3, when it is working.
Comment 9 Mike A. Harris 2002-12-19 06:27:46 EST
What is vterm?
Comment 10 adler 2002-12-19 06:54:50 EST
Vterm must be the virtual terminal. Basically he is talk about the functionality
of switching between switching between virtual terminals by typing <ctl><alt>FN.
Comment 11 Mike A. Harris 2002-12-29 04:03:54 EST
When using multiple video cards in a system, be sure to go into your CMOS
settings and make sure that the motherboard BIOS is initializing all video
hardware, and not just the primary card.  Also note that not all motherboards
allow this.

Also, you need to be sure that DRI is disabled on PCI Radeon hardware, as
DRI is not supported on PCI Radeon currently.

>After a fresh reboot, the XFree86 server does properly initalize the
>Radeon 7000 PCI card and it works properly. When I kill the X server
>and restart it, it fails to initialize it properly. The log from the
>X server reports that it fails to read the V_BIOS.

What do you mean by "kill" here exactly?  A clean proper X server shutdown,
a SIGKILL, or CTRL-ALT-BS, or something else?

Violent shutdown of the X server can potentially leave the video hardware
in a bad state requiring a hardware reset.
Comment 12 Mike A. Harris 2003-03-03 03:09:07 EST
ping - any updates in status here with newer beta releases?

Comment 13 Mike A. Harris 2003-04-25 06:29:34 EDT
Final ping...
Comment 14 Mike A. Harris 2003-11-29 09:36:31 EST
Working on PCI Radeon issues right now, and believe I've just
fixed PCI/AGP Radeon detection for good, and possibly other
PCI Radeon issues as well.

I assume due to lack of response that the problem reported in this
bug report has solved itself so I'm closing the bug as WORKSFORME,
as PCI Radeon properly configured works for me fine.

If the problem is still present and relevant, and you care to have
someone investigate it, feel free to respond to the above requests
I have made, and reopen the report and I'll be happy to reinvestigate
this issue.

TIA

Note You need to log in before you can comment on or make changes to this bug.