Bug 748798 - Xorg crashes when switching to console by Ctrl+Alt+Fn on RHEL 6 guests
Xorg crashes when switching to console by Ctrl+Alt+Fn on RHEL 6 guests
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
6.3
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
: Regression
: 835881 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 08:11 EDT by Marian Krcmarik
Modified: 2014-06-18 05:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-26 20:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (63.89 KB, text/plain)
2011-10-25 08:11 EDT, Marian Krcmarik
no flags Details
X.log (68.18 KB, text/plain)
2012-09-10 11:01 EDT, Marko Myllynen
no flags Details

  None (edit)
Description Marian Krcmarik 2011-10-25 08:11:56 EDT
Created attachment 530071 [details]
Xorg.log

Description of problem:
Xorg server crashes when switching to console by Ctrl+Alt+Fn shortcut on i386 guest. It does occur always when doing the switching first time after boot, after crash It does not occur on all guests always. Xorg.log in attachment. We had this problem some time ago and It was fixed that's why I consider it to be regression.

Version-Release number of selected component (if applicable):
xorg-x11-drv-qxl-0.0.14-10.el6.i686
Linux Guest - Linux localhost.localdomain 2.6.32-211.el6.i686 #1 SMP Tue Oct 18 15:55:38 EDT 2011 i686 i686 i386 GNU/Linux
spice-vdagent-0.8.1-2.el6.i686

How reproducible:
Always

Steps to Reproduce:
1. Connect with spice client to a Linux guest after booting the guest
2. Press Ctrl+Alt+Fn to switch into console.
  
Actual results:
Segfault

Expected results:
No segfault

Additional info:
On x86_64 I am not able to reproduce so far.
Comment 2 Christophe Fergeau 2012-02-28 05:30:53 EST
Here are some more details about how to reproduce (I have only asked some clarifications on IRC, I haven't tried to reproduce this)

1. start a linux guest
2. connect to it with spicec on a linux client
3. switch to a VT in the guest by pressing Ctrl+Alt+Fn (press Alt for a few seconds so that it sticks, and then press Ctrl+Fn)

Result: x.org on the guest segfaults
Expected result: no segfaults
Comment 4 Marko Myllynen 2012-09-10 11:00:11 EDT
I'm seeing the same problem on RHEL 6.3 + latest errata on x86_64. After booting up the guest and switching to a console X starts crashing constantly.

I'll attach Xorg.log with the xorg nevr's appended.

Thanks.
Comment 5 Marko Myllynen 2012-09-10 11:01:58 EDT
Created attachment 611471 [details]
X.log
Comment 6 Marko Myllynen 2012-09-10 11:02:35 EDT
*** Bug 835881 has been marked as a duplicate of this bug. ***
Comment 8 Marko Myllynen 2012-09-11 04:58:52 EDT
(In reply to comment #7)
> This patch looks like it might be relevant:
> 
> http://cgit.freedesktop.org/xorg/driver/xf86-video-qxl/commit/src/
> qxl_surface.c?id=f838df1589c63fba8e99200238cf0b4e3acac6b1

Thanks a lot for the pointer, I've rebuilt xorg-x11-drv-qxl-0.0.14-13.el6_2 with the patch and it fixed this issue.

Note You need to log in before you can comment on or make changes to this bug.