Bug 74891 - xfig exits with segfault
xfig exits with segfault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xfig (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 12:44 EDT by Mate Wierdl
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 16:35:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mate Wierdl 2002-10-02 12:44:11 EDT
Description of Problem:
cannot start xfig: it exits with segfault

Version-Release number of selected component (if applicable):

$ rpm -q xfig
xfig-3.2.3d-10

How Reproducible:

always (for me)
Steps to Reproduce:
1. type xfig
2. 
3. 

Actual Results:

$ xfig
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string
"-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,*--16-*"
to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string
"-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*"
to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string
"-*-times-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*"
to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Cannot convert string "7x13bold" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font
Segmentation fault

Expected Results:
No segfault, I guess.

Additional Information:

$ rpm -qa|grep font | sort
bitmap-fonts-0.2-2
chkfontpath-1.9.6-3
fontconfig-2.0-3
fonts-ISO8859-2-100dpi-1.0-8
fonts-ISO8859-2-1.0-8
fonts-ISO8859-2-75dpi-1.0-8
ghostscript-fonts-5.50-7
tetex-fonts-1.0.7-57
ttfonts-ja-1.2-16
urw-fonts-2.0-26
XFree86-100dpi-fonts-4.2.0-72
XFree86-75dpi-fonts-4.2.0-72
XFree86-base-fonts-4.2.0-72
XFree86-font-utils-4.2.0-72
XFree86-ISO8859-2-100dpi-fonts-4.2.0-72
XFree86-ISO8859-2-75dpi-fonts-4.2.0-72
XFree86-truetype-fonts-4.2.0-72
Comment 1 Ngo Than 2002-10-05 07:54:29 EDT
It's not a bug in xfig. It seems xfs (font server) is died in your case. Perhaps
you should restart your xfs again.

Comment 2 Mate Wierdl 2002-10-07 10:27:23 EDT
IMO it is hardly acceptable that xfig segfaults for this reason instead of
exciting gracefully.

In any case, something else is going on;look:

$ xfig; echo $?
0

# service xfs restart
Restarting xfs:
Shutting down xfs:                                         [  OK  ]
Starting xfs:                                              [  OK  ]

$ xfig

Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-
medium-r-normal--16-*-*-*-*-*-*-*,*--16-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-
medium-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-bo
ld-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Cannot convert string "7x13bold" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font
Segmentation fault

# service xfs status
xfs (pid 24408) is running...

If I restart the X server, all is well again.

Comment 3 Ngo Than 2006-05-05 16:35:22 EDT
it's not reproducible in current FC5 release.

Note You need to log in before you can comment on or make changes to this bug.