Bug 74893 - Firstboot bails when VT changes.
Summary: Firstboot bails when VT changes.
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 17:00 UTC by Stephen John Smoogen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-30 19:45:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen John Smoogen 2002-10-02 17:00:22 UTC
Description of Problem:

If you switch the VT terminal when firstboot is running, firstboot can exit
without warning.

Duplicated this problem twice also on the GX100 this morning. Video card   
is a i810. The way to duplicate the problem is to

do the firstboot,
in the RHN registration section, remove the wire or something to cause  
it to not be able to connect to the servers.
 
while it is waiting to timeout, switch to VT-1.
 
pop, firstboot exits and we are switched back to VT-7 as gdm startsup.

Comment 1 Brent Fox 2002-10-14 21:00:24 UTC
I have not been able to reproduce this, but the only i810 box I had died about
three months ago.  I will have to scrounge one up and test.  Other people have
reported some similar (but not identical) problems with i810 boards.

Comment 2 Stephen John Smoogen 2002-12-30 19:45:54 UTC
From an email with mike harris this is a bug with the i810 kernel module not
having the capability to switch the 'permissions' of the console. This bug shows
up when switching from a logged in XFree86 session to a virtual console so is
not  just firstboot bug. 

Closing since it is a kernel/XFree86 problem.


Note You need to log in before you can comment on or make changes to this bug.