Bug 749203 - mailq manpage does not display
mailq manpage does not display
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: postfix (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
: ManPageChange
Depends On: 664627
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-26 09:24 EDT by Peter Schiffer
Modified: 2011-10-26 13:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 664627
Environment:
Last Closed: 2011-10-26 13:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Schiffer 2011-10-26 09:24:14 EDT
+++ This bug was initially created as a clone of Bug #664627 +++

Description of problem:
Cannot display manpage for postfix's mailq(1) command.

Version-Release number of selected component (if applicable):
postfix-2.3.3-2.1.el5_2

How reproducible:
Always.

Steps to Reproduce:
1. yum install postfix && alternatives --set mta /usr/bin/sendmail.postfix && man mailq
2. Observe that "man mailq" fails (see below).

  
Actual results:
[root@mail ~]# man mailq
fopen: No such file or directory
Cannot open man page /usr/share/man/man1/sendmail.1.gz
No manual entry for mailq
[root@mail ~]#

Expected results:
[root@mail ~]# man mailq
(mailq manpage is displayed)

Additional info:
I think the "/usr/share/man/man1/mailq.postfix.1.gz" file is broken: it references "man1/sendmail.1", but the filesystem only has a "/usr/share/man/man8/sendmail.8.gz". Either that, or the sendmail manpage should be in category 1, not 8.

--- Additional comment from billycoutsis@gmail.com on 2010-12-20 20:57:19 EST ---

This bug may be CentOS-specific. My bad.

--- Additional comment from mstevens@etla.org on 2011-07-15 08:21:08 EDT ---

(In reply to comment #1)
> This bug may be CentOS-specific. My bad.

I'm also seeing this in "real" RHEL 5

--- Additional comment from pm-rhel@redhat.com on 2011-09-22 20:13:41 EDT ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

--- Additional comment from loye.young@rackspace.com on 2011-09-23 06:43:39 EDT ---

The following is a work around. 

<code>
ln -s /usr/share/man/man1/sendmail.postfix.1.gz /usr/share/man/man1/sendmail.1.gz
</code>

A symlink could be distributed with an updated rpm.

--- Additional comment from jskarvad@redhat.com on 2011-09-26 09:24:57 EDT ---

Created attachment 524904 [details]
Backported patch

There is same issue with newaliases. The backported patch should fix it all.

Note You need to log in before you can comment on or make changes to this bug.