Bug 74933 - Kicker crashes when accessing "Remove -> Button" menu via right-click
Kicker crashes when accessing "Remove -> Button" menu via right-click
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 17:39 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-02 17:39:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-02 17:39:03 EDT
Description of Problem:

Kicker crashes when one accesses the "Buttons" submenu from the "Remove" 
menu via a right-click on the panel.

Version-Release number of selected component (if applicable):

KDE version 3.0.3-8 Red Hat (the version that came with Red Hat 8.0)

How Reproducible:

I can reproduce it every time.

Steps to Reproduce:

1. Start KDE
2. Right-click on a blank area anywhere in the panel
3. Move the mouse over the "Remove" menu item
4. Move the mouse over the "Button" sub-menu item

Actual Results:

Kicker crashes and the panel disappears.

Expected Results:

A menu of buttons to remove should be presented.

Additional Information:

This is the output from the KDE crash handler:

(no debugging symbols found)...[New Thread 8192 (LWP 13232)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40f4ac63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x407221a5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x40c868f9 in QString::QString(QString const&) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#6  0x400bba27 in PanelRemoveButtonMenu::slotAboutToShow() ()
   from /usr/lib/kicker.so
#7  0x400baf60 in PanelRemoveButtonMenu::qt_invoke(int, QUObject*) ()
   from /usr/lib/kicker.so
#8  0x40a14d6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#9  0x40a14c57 in QObject::activate_signal(int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#10 0x40cef4ce in QPopupMenu::aboutToShow() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#11 0x40b01eab in QPopupMenu::subMenuTimer() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#12 0x40cef5f4 in QPopupMenu::qt_invoke(int, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#13 0x400b5dad in RemoveContainerMenu::qt_invoke(int, QUObject*) ()
   from /usr/lib/kicker.so
#14 0x40a14d6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#15 0x40a14c57 in QObject::activate_signal(int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#16 0x40cddb4b in QTimer::timeout() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#17 0x40a35792 in QTimer::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#18 0x409c0c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#19 0x409c04f1 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#20 0x406b69a6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#21 0x40963a88 in qt_activate_timers() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#22 0x40961330 in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#23 0x409c2280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#24 0x40b029b6 in QPopupMenu::exec(QPoint const&, int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#25 0x400641dc in Panel::showPanelMenu(QPoint) () from /usr/lib/kicker.so
#26 0x40072245 in PanelContainer::eventFilter(QObject*, QEvent*) ()
   from /usr/lib/kicker.so
#27 0x40a12e5e in QObject::activate_filters(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#28 0x40a12d81 in QObject::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#29 0x40a492ec in QWidget::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#30 0x409c0c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#31 0x409c0363 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#32 0x406b69a6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#33 0x40964b46 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#34 0x409619b6 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#35 0x4096152f in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#36 0x409c2280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#37 0x4096102d in QApplication::exec() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#38 0x40060a97 in main () from /usr/lib/kicker.so
#39 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

Kicker is easily restarted from a console window.  I did so, and had it 
crash so I could see what it spit back.  Here's what happened:

[wrhodes@hollyfeld wrhodes]$ kicker
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/DigitalClock) Negative sizes (2,-4) are 
not possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/QLabel) Negative sizes (49,-4) are not 
possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/DigitalClock) Negative sizes (2,-4) are 
not possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/QLabel) Negative sizes (49,-4) are not 
possible
[wrhodes@hollyfeld wrhodes]$ kicker: crashHandler called
KCrash: crashing.... crashRecursionCounter = 2
KCrash: Application Name = kicker path = <unknown> pid = 13428
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/DigitalClock) Negative sizes (2,-4) are 
not possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/QLabel) Negative sizes (49,-4) are not 
possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/DigitalClock) Negative sizes (2,-4) are 
not possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/QLabel) Negative sizes (49,-4) are not 
possible

I don't know if it helps, but this is on system which until yesterday had 
Red Hat 7.3 on it. I upgraded it to version 8.0 using the normal installer 
option.  Also, I'm using the 2.4.19-ac4 kernel.
Comment 1 Ngo Than 2002-10-05 07:29:36 EDT
strange, i cannot reproduce it ony many machines here. It works for me.

Note You need to log in before you can comment on or make changes to this bug.