Bug 74936 - orinoco_cs problem with when using SSL with wireless encryption enabled
orinoco_cs problem with when using SSL with wireless encryption enabled
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 17:55 EDT by Satish Balay
Modified: 2013-07-02 22:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2002-10-02 17:55:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
A very mysterious problem. When using a Lucent Wavelan PCMCIA Silver (64bit
encryption) card, if wireless incryption is enabled, https:// requests from
browser (mozilla/galeon/lynx) don't work. mozilla/galeon just hang, where lynx
gives ssl error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Redhat8.0 on a laptop (i've used IBM ThinkPad 600E)
2.insert Lucent Wavelan Silver PCMCIA 802.11b card. This by default loads
orinoco_cs driver
3.Set the correct wireless parameters using iwconfig something like:

/sbin/iwconfig eth0 essid correctID key correctNumericalKey


4. Now start up a web browser and try accessing a https:// site for eg:

lynx https://mail.yahoo.com
	

Actual Results:  [balay@localhost balay]$ lynx https://mail.yahoo.com

Looking up mail.yahoo.com
mail.yahoo.com
Making HTTPS connection to mail.yahoo.com
Secure 168-bit TLSv1/SSLv3 (EDH-RSA-DES-CBC3-SHA) HTTP connection
Sending HTTP request.
HTTP request sent; waiting for response.
Alert!: Unexpected network read error; connection aborted.
Can't Access `https://mail.yahoo.com/'
Alert!: Unable to access document.

lynx: Can't access startfile


Expected Results:  
Access should go through.

Additional info:

This problem  shows up with mozilla, galeon (no error messages, just hang most
of the time). I've tried a bunch of other https:// sites (including
https://bugzilla.redhat.com)

The problem disappears when I do any of the following:

1.Disable encryption for wireless netowrk.
2.Use a wired (ethernet) network
3.use wvlan_cs driver instead of orinico_cs (This is the default for redhat 7.2
which has worked fine without problems for me)
4. Using an Orinoco Gold card with 128bit encryption.

Perhaps this bug report can be forwarded upsteam to orinoco_cs developers?

I still can't comprehend how 'a driver bug' (if thats what it is) can affect ssl
connections only. So far I have't seen any other weird behavior. Regular web
browsing is not affected. My ssh connections work fine.
Comment 1 John A. Barbuto 2002-10-06 16:01:55 EDT
I'm using an Orinoco Gold card with 128 bit encyption with a Linksys WAP11
access point, and I'm having this problem as well.  It also affects the
operation of up2date, since it uses SSL.  I didn't have this problem with 7.3.
Comment 2 Need Real Name 2002-10-08 15:28:30 EDT
I don't know if this is helpful, but this isn't an "Always" problem here. I have
8.0, an Orinoco Silver with WEP enabled using orinoco_cs, and I have no problem
getting to https sites. Running in Ad-Hoc mode.  Happy to supply any more
relevant information if anyone can think of any.

Comment 3 Bugzilla owner 2004-09-30 11:39:58 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.