Bug 74956 - Hwbrowser dies.
Hwbrowser dies.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 73225 75695 75767 76632 76666 77583 78100 79527 81627 81983 82070 83493 85720 89202 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 23:28 EDT by Ali-Reza Anghaie
Modified: 2007-04-18 12:47 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:31:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of RPMs installed on HP Pav 9996 (13.25 KB, text/plain)
2002-10-05 15:17 EDT, Need Real Name
no flags Details
console strace of "hwbrowser" (39.60 KB, text/plain)
2002-11-16 12:41 EST, baulv
no flags Details
strace output for hwbrowser crash. (40.62 KB, text/plain)
2003-04-09 18:52 EDT, sean johnston
no flags Details

  None (edit)
Description Ali-Reza Anghaie 2002-10-02 23:28:04 EDT
Description of Problem:   
   
'hwbrowser' either via consolewrapper or on its own dies. Status box pops up 
and the template pops up and *bang* it dies: 
 
-- BEGIN ERROR OUTPUT -- 
** (hwbrowser:31499): WARNING **: gdk_keyboard_grab returned 3 
 
(DeviceList.py:31504): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: 
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed 
 
(DeviceList.py:31504): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: 
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed 
 
<snip> 
 
Traceback (most recent call last): 
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ? 
    reread_device_type_list () 
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in 
reread_device_type_list 
    list.set (iter, 0, hardware.get_category_string (key), 1, key) 
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string 
    return self.type_mapping[key] 
KeyError: 20 
-- END ERROR OUTPUT -- 
   
Version-Release number of selected component (if applicable):   
   
hwbrowser-0.6-1 
libgnomecanvas-2.0.2-1 
 
How Reproducible:   
 
Always, three different setups. GNOME or KDE, etc.  
   
Steps to Reproduce:   
1. Run 'Hardware Browser' from menu or 'hwbrowser' from prompt. 
2. Type in passwd if needed. 
3. Watch it go *bang* .. 
   
Actual Results:   
 
'hwbrowser' dies. 
   
Expected Results:   
 
Expect a Hardware Browser to come up.   
 
Additional Information:  
 
Nada. Cheers, -Ali
Comment 1 Need Real Name 2002-10-04 05:51:47 EDT
I am experiencing exactly the same bug on a Dell i8100 laptop 
with Red Hat 8.0.

It does NOT occur on other PC's on which I have also installed Red Hat 8.0.

There is no difference in the installed packages or setups that might
account for this crashing on the i8100 but not on the other machines.
Comment 2 oskar 2002-10-05 07:21:44 EDT
Getting something similar.

Starting from the menu it pops up and dies (each time the same).
Starting it from a terminal it gives me (each time the same):

(A lot of these lines first, 15 in total)
=================start of output
(DeviceList.py:13911): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:13911): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20
=================end of output

Installed version
hwbrowser-0.6-1
libgnomecanvas-2.0.2-1

Reproduces the same results every time.
Same as above:
1. Run 'Hardware Browser' from menu or 'hwbrowser' from prompt. 
2. Type in passwd if needed. 
3. Watch it go *bang* .. 

Results are that it dies on me.

Additional information
used LVM (for partitions / /usr /var /home /tmp) and separate /boot
SB Audigy is detected but does not give sound
Comment 3 Need Real Name 2002-10-05 15:16:06 EDT
Me too on a HP Pavilion 9995.
Comment 4 Need Real Name 2002-10-05 15:17:30 EDT
Created attachment 78944 [details]
List of RPMs installed on HP Pav 9996
Comment 5 Need Real Name 2002-10-06 13:24:27 EDT
Ditto on this RH 8.0 P4 1.7 box
Comment 6 Youssef Makki 2002-10-06 21:44:58 EDT
Have the same problem on RH 8.0, hwbrowser dies with the following errors:

$ hwbrowser

(DeviceList.py:6672): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:6672): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:6672): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:6672): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:6672): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:6672): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:6672): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 204, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 151, in reread_device_type_lis
t
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 92, in get_category_string
    return self.type_mapping[key]
KeyError: 10

Tried a fix which worked, as suggested by mitr. Added the following to line 67
of /usr/share/hwbrowser/DeviceList.py :

kudzu.CLASS_FIREWIRE : _("Firewire"),

hwbrowser gives the following output when run but does not die:

$ hwbrowser

(DeviceList.py:11130): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:11130): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:11130): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:11130): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:11130): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:11130): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:11130): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

I have a Creative Audigy soundcard, the firewire port shows up in hwbrowser.
Comment 7 John Mizell 2002-10-07 11:50:08 EDT
I too have this same problem on Dell Inspiron 8000
Comment 8 Dave 2002-10-07 18:44:24 EDT
I also get the exact same error (with same error text)

Dell Latitude C800

Did not experience this error on my Dell Dimension XPS-R400
Comment 9 oskar 2002-10-10 09:53:34 EDT
Tried the fix described above and that works for me as well. Sames output as
described, but the hwbrowser does not die on me.

Tried a fix which worked, as suggested by mitr. Added the following to line 67
of /usr/share/hwbrowser/DeviceList.py :

kudzu.CLASS_FIREWIRE : _("Firewire"),



Comment 10 John Mizell 2002-10-10 10:42:55 EDT
The fix worked for me. Now if redhat can roll it out with rhn.
Comment 11 Need Real Name 2002-10-11 07:07:30 EDT
Adding the Firewire changed nothing for me:

(DeviceList.py:1376): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed):
assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 204, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 151, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 92, in get_category_string
    return self.type_mapping[key]
KeyError: 20
Comment 12 Eric Smith 2002-10-15 03:43:22 EDT
Firewire fix worked for me as well.  The browser doesn't show my firewire
devices,though - three hard drives, two CD-Rs, and one DVD-R, on two host
adapters, a Creative Labs Audigy and a generic OHCI card.  I don't think
that's the browser's fault, kudzu isn't finding and configuring the drives.

Comment 13 Need Real Name 2002-10-15 14:24:47 EDT
I'm having the same problem on an HP Pavilion 7960 desktop. From a console or
through GUI, the window outline for hwbrowser appears and then exits. The
following two lines appear in the messages.log file each time hwbrowser is started:

Oct 15 11:17:30 localhost kernel: parport0: PC-style at 0x378 (0x778)
[PCSPP,TRISTATE,EPP]
Oct 15 11:14:53 localhost kernel: parport0: irq 7 detected

The "irq 7" makes me wonder if it's related to RH 8.0's failure to use the
Ensoniq ES1371 sound card in this system.  Still, hwbrowser should stay alive.
Comment 14 Daniel Brewer 2002-10-24 16:51:10 EDT
Same here on an Atlon XP 2000+ i686 Redhat 8.0.  Removing and re-installing does
not make a difference.
Comment 15 Dominique Coissard 2002-10-25 12:42:47 EDT
*** Bug 76632 has been marked as a duplicate of this bug. ***
Comment 16 Daniel Brewer 2002-10-26 06:19:09 EDT
Firewire fix worked for me also.  All devices including firewire show.  Still
gets canvas errors, but does run.
Comment 17 Jonathan Blandford 2002-10-30 15:12:25 EST
*** Bug 76666 has been marked as a duplicate of this bug. ***
Comment 18 Jonathan Blandford 2002-10-30 15:13:32 EST
*** Bug 75767 has been marked as a duplicate of this bug. ***
Comment 19 Gerald Teschl 2002-11-13 08:31:49 EST
Same problem here as well (Sony vaio FX702 laptop):

Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20
Comment 20 baulv 2002-11-16 12:39:06 EST
I get the same results. See enclosed strace-hwbrowser .txt file
Comment 21 baulv 2002-11-16 12:41:04 EST
Created attachment 85304 [details]
console strace of "hwbrowser"
Comment 22 Need Real Name 2002-12-12 00:47:17 EST
Tried the workaround described above (editing the DeviceList.py file), and it
helps.  The Hardware Browser will now start up without crashing.  HOWEVER... it
only works properly if I do not have a hard drive partition mounted via the
Firewire interface.  If a partition on the Firewire hard drive is mounted,
Hardware Browser hangs (but does not crash) until the partition is unmounted.
Comment 23 Ali-Reza Anghaie 2002-12-18 03:41:49 EST
*** Bug 79527 has been marked as a duplicate of this bug. ***
Comment 24 Manu 2003-01-01 12:28:07 EST
I had the same problem on a sony vaio laptop with a fire wire port. The one line
entry suggested worked and the hwbroser didnt die, but compalined of stuff.

Thanks a lot guys.
Comment 25 Geraldo Veiga 2003-01-04 13:51:38 EST
I am running RH 8.0 on a Dell Inspiron 8100. I get exactly the same problem as
described in other messages above.  The proposed fix also cured it: 


Add the following to line 67 of /usr/share/hwbrowser/DeviceList.py :

kudzu.CLASS_FIREWIRE : _("Firewire"),
Comment 26 Brent Fox 2003-01-08 17:59:42 EST
I've applied the line to cvs and built a new version that should appear in
Rawhide tomorrow.  hwbrowser-0.7-2 should fix the problem.  QA, please verify. 
Note that you will need to test the fix with a machine that has a firewire port.
Comment 27 Brent Fox 2003-01-08 18:00:36 EST
*** Bug 75695 has been marked as a duplicate of this bug. ***
Comment 28 Brent Fox 2003-01-08 18:01:07 EST
*** Bug 73225 has been marked as a duplicate of this bug. ***
Comment 29 Brent Fox 2003-01-08 18:02:42 EST
*** Bug 78100 has been marked as a duplicate of this bug. ***
Comment 30 Need Real Name 2003-01-08 18:13:29 EST
I would just like to point out that the DeviceList.py change did not COMPLETELY
fix the problem for me. Yes, it allowed HW Browser to start up without crashing;
but HW Browser would still hang (after starting) if there was a partition from
the Firewire hard drive mounted.
Comment 31 Brent Fox 2003-01-08 18:35:28 EST
uchima: please open a separate bug report for that.  It is a related problem,
but ultimately separate from the original report.
Comment 32 Nick Dimiduk 2003-01-09 00:30:34 EST
This problem (the "GnomeCanvas-CRITICAL" error mentioned above) started occuring
for me when I upgraded my motherboard from an Abit KT7A-raid to the Asus
A7V8X-raid.  I did NOT have this problem proir to the installation of my new
motherboard.  Also, I get a similar error when I try to run the
"redhat-config-date" utility.
Comment 33 John Gotts 2003-01-09 15:29:27 EST
I also have an A7V8X motherboard and the stock 8.0 hwbrowser crashes but it now
works after applying the fix from comment 25.
Comment 34 Brent Fox 2003-01-09 16:26:57 EST
Nick: the "GnomeCanvas-Critical" errors you are seeing is from the Gnome Canvas
widget, which both hwbrowser and redhat-config-date (and anaconda for that
matter, although the error messages are hidden on VC1).  I recommend you file a
bug against gnome-python2-canvas, which is the RPM that the python gnome canvas
module is in.
Comment 35 Brent Fox 2003-01-13 02:00:25 EST
*** Bug 81627 has been marked as a duplicate of this bug. ***
Comment 36 Mike Becker 2003-01-13 15:28:22 EST
I am using Red Hat 8.0 in an HP Pavilion 750n system and the hwbrowser bug also
got me.  However, by adding the above talked about fix to line 67 of
DeviceList.py took care of things quite nicely.  Thanks...
Comment 37 Brent Fox 2003-01-15 19:55:30 EST
*** Bug 81983 has been marked as a duplicate of this bug. ***
Comment 38 Brent Fox 2003-01-16 22:21:43 EST
*** Bug 82070 has been marked as a duplicate of this bug. ***
Comment 39 Andy Wallace 2003-01-31 18:46:46 EST
Brent, you could probably answer this best.
I am having this same problem during the initial install. I am on a Dell
Dimension 8100. Since it is the initial install, it fails, exits abnormally and
states it is safe to reboot the machine. After reboot I have a grub prompt.

How can I make this change mentioned in comment 25 above?

For your reference, I am installing from a DVD out of the book "The Complete
Reference Red Hat Linux 8 DVD Edition" by Richard L. Petersen.ISBN 0-07-222646-3.
Comment 40 Brent Fox 2003-01-31 18:57:12 EST
ajwalla: hwbrowser does not run during the initial install.  Are you sure you're
seeing the exact same problem?
Comment 41 Andy Wallace 2003-01-31 19:13:15 EST
Maybe I'm not so sure. Here's what was on the screen when the install failed:

(anaconda:87): GnomeCanvas - CRITICAL **: file gnome-canvas-path-def.C: line 1142
(gnome_canvas_path_def_any_closed): assertion 'path != NULL' failed
install exited abnormally

... at this point, abunch of shutdown message lines.

last line was something like "it is now safe to reboot your system".

This all occured just about a minute after that last next click before
the formats started.

I was unable to cut and paste, so this is from hand written notes. :^)
Comment 42 Brent Fox 2003-01-31 21:18:33 EST
Andy: I'm certain that this is a different problem.  The messages related to
GnomeCanvas don't have anything to do with either one of these crashes.  Both
anaconda and hwbrowser use a GnomeCanvas widget.  The python bindings for
GnomeCanvas for some reason writes a lot of debug messages to the command line,
but it doesn't cause a crash.

It's the part of the debug that starts with "Traceback (most recent last call)"
that really provides information about the crash.  Do you see any information
like that with the installer when it crashes?
Comment 43 Andy Wallace 2003-02-01 12:35:36 EST
Brent: I reran the install in text mode. I got an option to load the bootloader
in the MBR or at the /boot mount point, there was no default selected. I don't
remember getting this option in the several install runs I did in graphics mode.
I selected MBR. This is the only difference in my last two install attempts 
other than my last attempt using text mode vrs graphics. The last install was
successful. If I can help you trouble shoot this, please let me know.
Comment 44 Brent Fox 2003-02-03 11:36:54 EST
Andy: The thing for you to do is to file a new bug report against anaconda (the
installer).  The crash that you originally saw is clearly caused by something in
the installer's GUI code.  

It will really help the installer team if you can provice the Traceback debug
info.  When the installer crashes, it should pop up a dialog asking you to
insert a floppy and it will copy the debug data to it.  Then you can attach that
data to the bug report when you file it.  

In any case, I'm convinced that the problem you are seeing has nothing to do
with hwbrowser and belongs in a separate bug report.  Thanks for your help.
Comment 45 Brent Fox 2003-02-04 16:57:46 EST
*** Bug 83493 has been marked as a duplicate of this bug. ***
Comment 46 Brent Fox 2003-03-10 12:32:01 EST
*** Bug 85720 has been marked as a duplicate of this bug. ***
Comment 47 eric draven 2003-03-14 02:21:17 EST
I'm getting the same problem as Andy, redhat 8 install failing, but on a celeron
300a system. This is my 3rd time trying, same error every time, even tried
installing with kde instead of gnome and are still getting this error. 

(anaconda:76): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: line 1142
(gnome_canvas_path_def_any_closed): assertion 'path != NULL' failed

above is repeated 8 times, then says
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
(snip)
unmounting filesystems...
(snip)
ejecting /tmp/cdrom...
you may safely reboot your system
Comment 48 Brent Fox 2003-03-18 14:14:23 EST
*** Bug 77583 has been marked as a duplicate of this bug. ***
Comment 49 sean johnston 2003-04-09 18:52:21 EDT
Created attachment 91053 [details]
strace output for hwbrowser crash.

Ya, I am realy vexed!
Comment 50 Gerald Teschl 2003-04-21 07:30:31 EDT
Everything works fine for me under 9.
Comment 51 Brent Fox 2003-04-21 15:08:59 EDT
*** Bug 89202 has been marked as a duplicate of this bug. ***
Comment 52 Brent Fox 2003-05-25 10:31:01 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.