This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 749603 - abrt-ccpp not enabled when upgrading from F15 to F16
abrt-ccpp not enabled when upgrading from F15 to F16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
CommonBugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-27 12:19 EDT by Jonathan Kamens
Modified: 2014-02-02 17:15 EST (History)
12 users (show)

See Also:
Fixed In Version: abrt-2.0.7-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-16 14:52:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2011-10-27 12:19:17 EDT
When yum upgrading from F15 to F16, abrt core reporting works fine before the upgrade and stops working afterward. User needs to us "systemctl enable abrt-ccpp.service" and "systemctl start abrt-ccpp.service" (or reboot) to get it to start working again.
Comment 1 Jonathan Kamens 2011-10-27 13:33:25 EDT
Changing summary because adamw says this occurs on any F15 -> F16 upgrade, not just when upgrading via yum.

This probably makes it a somewhat higher priority bug to fix? Maybe even a blocker?
Comment 2 Michael Cronenworth 2011-11-23 12:54:28 EST
(In reply to comment #1)
> This probably makes it a somewhat higher priority bug to fix?

+1. This is broken for preupgrade users (and probably DVD), too. I had to manually enable and start the abrt-ccpp service.

$ rpm -q abrt
abrt-2.0.6-1.fc16.x86_64
Comment 3 Fedora Update System 2011-12-10 06:05:22 EST
abrt-2.0.7-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.7-2.fc16
Comment 4 Fedora Update System 2011-12-11 16:56:55 EST
Package abrt-2.0.7-2.fc16, libreport-2.0.8-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.7-2.fc16 libreport-2.0.8-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16990/libreport-2.0.8-3.fc16,abrt-2.0.7-2.fc16
then log in and leave karma (feedback).
Comment 5 David Kovalsky 2011-12-13 11:06:19 EST
I'm running with abrt-2.0.7-2.fc16.x86_64, but that didn't help in my case (see bug 767001).

Running `systemctl enable abrt-ccpp.service' does the trick, but I'd expect abrt install to do that for me.
Comment 6 Fedora Update System 2011-12-16 14:52:57 EST
abrt-2.0.7-2.fc16, libreport-2.0.8-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.