Bug 74967 - Installer doesn't turn on swap soon enough
Installer doesn't turn on swap soon enough
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 03:57 EDT by Stuart Inglis
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-03 03:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Inglis 2002-10-03 03:57:48 EDT
Description of Problem:

When I choose graphical install on a Pentium 166 with 48M of RAM it dies with an
OOM exception. Alt-F2/free shows swap hasn't been enabled.

Version-Release number of selected component (if applicable):

8.0

How Reproducible:

Every time.

Steps to Reproduce:
1. Try installing on a machine with 48M ram
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

I tried turning on the swap manually (alt-f2/mkswap/swapon etc), this got
further but i got to a stage where it failed turning on swap and the only option
was to reboot. This was mean I know, it should probably have checked again....
	
To get around this I installed in text mode. Everything work ok in text mode.
Comment 1 Michael Fulbright 2002-10-03 13:33:38 EDT
Minimum memory requirement is 64MB.
Comment 2 Stuart Inglis 2002-10-03 15:15:15 EDT
Not a bug? If the minimum is 64M then it should have stopped the installation 
process and said this. Instead it died in what looked like a tcl/tk place with 
a stack trace and gave the option to debug.

By any definition that's a bug!

Note You need to log in before you can comment on or make changes to this bug.