Bug 749853 - backport new python-rhsm API calls present in 6.2 for 5.8
backport new python-rhsm API calls present in 6.2 for 5.8
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-rhsm (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.8
Assigned To: William Poteat
IDM QE LIST
:
Depends On:
Blocks: 715031
  Show dependency treegraph
 
Reported: 2011-10-28 13:42 EDT by Chris Duryee
Modified: 2012-02-21 01:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No Description Needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:44:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2011-10-28 13:42:12 EDT
Description of problem:

As part of RHEL 5.8, subscription-manager will have some new features that were introduced in 6.2. The 5.8 version of python-rhsm requires certain features to be backported from 6.2 in order to support this. These features are already supported in candlepin, this bug is just for exposing these via the python-rhsm wrapper.

Specifically:

* new bind API call
* new API calls for environment information
* package profiling API
* expose stacking ID from entitlement cert
* expose virt-only flag from entitlement cert

The QE for this is already laid out in the subscription-manager 5.8 plan; python-rhsm is a library used by subscription-manager that is not tested by itself.
Comment 1 RHEL Product and Program Management 2011-10-28 13:47:46 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 Chris Duryee 2011-10-28 15:08:33 EDT
6cab931516a58d4b84023279ec1045becd423efd master 0.98.2+
Comment 4 J.C. Molet 2011-12-08 10:56:06 EST
This is a general bug porting functionality from 6.2 to 5.8.  the 5.8 version of rhsm wouldn't work at all if this wasn't done apperently.

The smoke tests are passing: 

http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/Entitlement/job/subscription-manager%20%28Stage%29%20RHEL5.8%20Acceptance/43/TestNG_Report/

Showing that these fixes made it.

Marking VERIFIED.
Comment 5 William Poteat 2012-01-27 09:23:30 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Description Needed
Comment 6 errata-xmlrpc 2012-02-21 01:44:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0280.html

Note You need to log in before you can comment on or make changes to this bug.