Bug 750055 - [abrt] Zim-0.53-1.fc16: index.py:1483:get_all_pages_index:AssertionError: BUG: could not find path in index
[abrt] Zim-0.53-1.fc16: index.py:1483:get_all_pages_index:AssertionError: BUG...
Status: CLOSED DUPLICATE of bug 838100
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:8f195c69d45d8eb6b94c757c65c...
:
: 724950 740209 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-30 09:05 EDT by Pierguido Lambri
Modified: 2012-07-06 11:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 11:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierguido Lambri 2011-10-30 09:05:21 EDT
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        /usr/bin/python /usr/bin/zim
comment:        Copy& paste from Zim 
executable:     /usr/bin/zim
kernel:         3.1.0-1.fc16.x86_64
reason:         index.py:1483:get_all_pages_index:AssertionError: BUG: could not find path in index
time:           Sun Oct 30 13:04:01 2011
uid:            1000
username:       pier

backtrace:
:index.py:1483:get_all_pages_index:AssertionError: BUG: could not find path in index
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 761, in on_open_page
:    self.treeview.select_page(path)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 635, in select_page
:    model.select_page(path)
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 55, in select_page
:    for treepath in self.get_treepaths(mypath):
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 494, in get_treepaths
:    pageindex = self.index.get_all_pages_index(p)
:  File "/usr/lib/python2.7/site-packages/zim/index.py", line 1483, in get_all_pages_index
:    assert False, 'BUG: could not find path in index'
:AssertionError: BUG: could not find path in index
:
:Local variables in innermost frame:
:i: 67
:cursor: <sqlite3.Cursor object at 0x1bbd9d0>
:path: <IndexPath: Home:Debug boot logs>
:self: <Index object at 0x1ad00f0 (zim+index+Index at 0x1b5c860)>
:row: <sqlite3.Row object at 0x1bc2470>

smolt_data:
:
:
:General
:=================================
:UUID: 087f8790-876c-4894-a14b-f21c3186f344
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_GB.utf8
:Platform: x86_64
:BogoMIPS: 5053.34
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 540  @ 2.53GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2534
:System Memory: 3754
:System Swap: 4093
:Vendor: LENOVO
:System: 2537CT4 ThinkPad T410
:Form factor: Notebook
:Kernel: 3.1.0-1.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4480:59426:6058:8499) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(4480:57904:6058:8500) pci, None, BASE, Memory Stick Host Controller
:(4480:59442:6058:8502) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(32902:11362:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:6058:8595) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:6058:8598) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:6058:8598) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:6058:8551) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15151:6058:8552) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15111:6058:8550) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:6058:8592) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:4330:6058:8531) pci, e1000e, ETHERNET, 82577LM Gigabit Network Connection
:(32902:9288:6058:8549) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:6058:8543) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:16952:32902:4369) pci, iwlagn, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:70:6058:8538) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15178:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:6058:8542) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_piernb-root / ext4 4096 4096 12603057 11118702 10478498 3203072 3012940 3012940
:/dev/mapper/luks-e8fd0e87-c105-4682-8678-c38951f0c26e /home ext4 4096 4096 24689563 7278700 6024531 6275072 5636318 5636318
:
Comment 1 Robin Lee 2011-10-30 10:02:00 EDT
Any idea about reproducing this issue?
Comment 2 Pierguido Lambri 2011-10-30 10:12:28 EDT
I've tried now few combo keys, but nothing happened.
Anyway I'm using Zim daily in my work and I'll see if I can reproduce it.
Comment 3 Nuno Anjos 2011-11-23 08:07:44 EST
Package: Zim-0.53-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
drag tag to another place
Comment 4 Nuno Anjos 2011-11-23 08:17:04 EST
Package: Zim-0.53-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
drag tag to another place
Comment 5 Nuno Anjos 2011-11-28 05:21:48 EST
Package: Zim-0.53-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
drag tag inside
Comment 6 Robin Lee 2011-12-16 04:58:46 EST
*** Bug 740209 has been marked as a duplicate of this bug. ***
Comment 7 Robin Lee 2011-12-16 05:16:24 EST
*** Bug 724950 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Admin XMLRPC Client 2012-01-10 22:24:16 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Robin Lee 2012-07-06 11:38:48 EDT

*** This bug has been marked as a duplicate of bug 838100 ***

Note You need to log in before you can comment on or make changes to this bug.