Bug 75007 - workaround for: yppush does not work
workaround for: yppush does not work
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 13:15 EDT by Konstantin Olchanski
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-04 11:25:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Olchanski 2002-10-03 13:15:46 EDT
Description of problem:
Stock RedHat Linux 7.3 ypserv/yppush cannot push updated maps to slave nis
servers (redhat linux 7.3 or 7.2), see bug 62429 for more details.
My solution is to install ypserv-2.5-1 (presumably same as in redhat linux 8.0)
on all machines and rebuild the slave server maps. Then yppush works.
K.Olchanski
Comment 1 Alexander Larsson 2002-10-07 05:52:23 EDT
7.3 packages are coming.
Comment 2 Konstantin Olchanski 2002-11-01 16:48:00 EST
Installed the errata ypserv-2.5-2.7x (why does 7.x errata overwrite an 8.0
package?) and pushing maps to slave servers stopped working. This is what I get:

[root@e614db yp]# cd /var/yp
[root@e614db yp]# make
gmake[1]: Entering directory `/var/yp/E614-NIS'
gmake[1]: `ypservers' is up to date.
gmake[1]: Leaving directory `/var/yp/E614-NIS'
gmake[1]: Entering directory `/var/yp/E614-NIS'
Updating netgroup...
netgroup->sam.triumf.ca: Callback timed out
netgroup->jam.triumf.ca: Callback timed out
Updating netgroup.byhost...
netgroup.byhost->sam.triumf.ca: Callback timed out
netgroup.byhost->jam.triumf.ca: Callback timed out
Updating netgroup.byuser...
...

K.O.
Comment 3 Konstantin Olchanski 2002-11-01 18:47:52 EST
Scratch the previous bug report. The problem was traced to inconsistent NIS
maps: on the NIS server, "ypwhich -m" reported names like "hosts.byname
e614db.Triumf.CA", while on the slave "ypwhich -m" reported "hosts.byname
e614db.triumf.ca" (notice the domain name is in lower-case). After rebuilding
slave NIS maps, "ypwhich -m" returns the same hostnames and yppush works again.
K.O.
Comment 4 Alexander Larsson 2002-11-04 11:25:08 EST
It's unfortunate that it overwrites the 8.0 packages, but it does have some
fixes not in the 8.0 version. Anyway. closing bug.

Note You need to log in before you can comment on or make changes to this bug.