This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 750216 - cannot boot into F16 after preupgrading from F15 to F16
cannot boot into F16 after preupgrading from F15 to F16
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
16
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-31 07:28 EDT by Hongqing Yang
Modified: 2011-10-31 22:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-31 22:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda logs (230.00 KB, application/x-tar)
2011-10-31 07:28 EDT, Hongqing Yang
no flags Details
grub conf (1.24 KB, application/octet-stream)
2011-10-31 07:55 EDT, Hongqing Yang
no flags Details
grub conf (1.24 KB, text/plain)
2011-10-31 08:18 EDT, Hongqing Yang
no flags Details
ks file genereated by preupgrade (283 bytes, text/plain)
2011-10-31 08:28 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2011-10-31 07:28:45 EDT
Created attachment 530952 [details]
anaconda logs

Description of problem:
after preupgrading from F15 to F16, the grub2.cfg links to /boot/grub2/grub.cfg, the /boot/grub2/ directory does not exist.
after modify grub.cfg to boot from 'Upgrade to Fedora 16 Branched Pre-release(Verne)', it still cannot not boot.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. install F15
2. install preupgrade 1.1.10_1
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-10-31 07:55:10 EDT
Created attachment 530957 [details]
grub conf
Comment 2 Hongqing Yang 2011-10-31 08:18:49 EDT
Created attachment 530963 [details]
grub conf
Comment 3 Hongqing Yang 2011-10-31 08:28:36 EDT
Created attachment 530965 [details]
ks file genereated by preupgrade
Comment 4 Hongqing Yang 2011-10-31 08:40:42 EDT
(In reply to comment #0)
> Created attachment 530952 [details]
> anaconda logs
> 
> Description of problem:
> after preupgrading from F15 to F16, the grub2.cfg links to
> /boot/grub2/grub.cfg, the /boot/grub2/ directory does not exist.
> after modify grub.cfg to boot from 'Upgrade to Fedora 16 Branched
> Pre-release(Verne)', it still cannot not boot.
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 100%
> 
> Steps to Reproduce:
> 1. install F15
> 2. install preupgrade 1.1.10_1
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Correct the description:
there is only grub.cfg under /etc, there is no grub2.cfg. 
and all anaconda logs in /var/log/ are not touched.
after installation , the preupgrade directory under root / is empty.
Comment 5 Mads Kiilerich 2011-10-31 09:40:01 EDT
This indicates that 
1: the old f15 kernels has been removed
2: grub2 wasn't installed
3: anaconda didn't finish correctly

One way to investigate it further could be to look for anaconda log files in /tmp while upgrading.
Comment 6 Adam Williamson 2011-10-31 12:00:28 EDT
hong: preupgrade is a two-step process: once you install preupgrade into F15, then run it and let it download all the upgrade packages, you're supposed to reboot and it boots into anaconda to complete the upgrade. That's what the 'Upgrade to Verne' bootloader entry is for.

When you say "after modify grub.cfg to boot from 'Upgrade to Fedora 16 Branched
Pre-release(Verne)', it still cannot not boot.", what do you mean exactly?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Hongqing Yang 2011-10-31 22:18:22 EDT
(In reply to comment #6)
> hong: preupgrade is a two-step process: once you install preupgrade into F15,
> then run it and let it download all the upgrade packages, you're supposed to
> reboot and it boots into anaconda to complete the upgrade. That's what the
> 'Upgrade to Verne' bootloader entry is for.
> 
> When you say "after modify grub.cfg to boot from 'Upgrade to Fedora 16 Branched
> Pre-release(Verne)', it still cannot not boot.", what do you mean exactly?
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

yeah, it is not a bug. It was F16 when I come this morning.

Note You need to log in before you can comment on or make changes to this bug.