Bug 75022 - kernel build for ahtalon actually is done for i686
kernel build for ahtalon actually is done for i686
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 15:50 EDT by adler
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 20:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2002-10-03 15:50:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Reading over the .spec file and associated patch files for the 2.4.18-14 kernel,
you build an i686 kernel when the target is athlon.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get the kernel src.rpm file
2.install it
3.check spec and patch files
	

Additional info:

the patch file in question is: linux-2.4.18-smallpatches.patch. The
chuck in question is:

--- linux/arch/i386/Makefile~	Wed Aug  8 12:34:56 2001
+++ linux/arch/i386/Makefile	Wed Aug  8 17:40:17 2001
@@ -63,7 +63,7 @@
 endif
 
 ifdef CONFIG_MK7
-CFLAGS += $(shell if $(CC) -march=athlon -S -o /dev/null -xc /dev/null
>/dev/null 2>&1; then echo "-march=athlon"; else echo "-march=i686
-malign-functions=4"; fi) 
+CFLAGS += -march=i686 -malign-functions=4 
 endif
 
I've replaced the above code with

 ifdef CONFIG_MK7
-CFLAGS += $(shell if $(CC) -march=athlon -S -o /dev/null -xc /dev/null
>/dev/null 2>&1; then echo "-march=athlon"; else echo "-march=i686
-malign-functions=4"; fi) 
+CFLAGS += $(shell if $(CC) -march=athlon -S -o /dev/null -xc /dev/null
>/dev/null 2>&1; then echo "-march=athlon"; else echo "-march=i686
-falign-functions=4"; fi) 
 endif
 
and rebuilt the kernel rpms and installed them for the athlon target.
It seems to be running fine. I don't understand why you forced
the -march=i686 for athlons.
Comment 1 Arjan van de Ven 2002-10-03 15:55:06 EDT
we do this because -mathlon isn't actually tested a lot and has been buggy in
general :(

What the athlon kernel *does* bring are the fast memcpy/memset functions, which
are about 2x faster than the non-athlon ones.....
Comment 2 adler 2002-10-03 16:01:16 EDT
well, I do notice a general speed up of my desktop with this new kernel. Would
you like for me to report any anomolies? so far the system is doing fine.
Comment 3 Arjan van de Ven 2002-10-03 16:04:24 EDT
I'm absolutely interested in success/failure reports.
I might not be able to DO anything with it like dropping the patchlet soon
(right now I try to have a tree that compiles with both gcc 2.96 and 3.2, and I
*know* 2.96 -mathlon was bust), but in the future I will...
Comment 4 adler 2002-10-03 16:08:49 EDT
I will keep you guys posted.
Comment 5 adler 2002-10-03 17:27:44 EDT
do you guys want me to run a stress test on my recently built athlon system?
Comment 6 Arjan van de Ven 2002-10-03 17:30:45 EDT
I'm actually more worried about certain device drivers breaking. Stress tests
are good at finding broken algorithms in code, but miscompiles usually hit the
very first time code gets executed. And also device drivers tend to be more
sensitive to miscompiles due to, ehm, "sometimes questionable code quality".
Comment 7 adler 2002-10-03 18:38:19 EDT
hmmm... the only way to really test this is through a large user base. I suggest
that for the next beta release, you make sure the -march=athlon is set for the
athlon kernel build. Prety much all my devices have been tested with the athlon
built kernel I'm running... As I said, I'll keep you posted.

Note You need to log in before you can comment on or make changes to this bug.