Bug 750245 - Can't generate hello world pdf if type is Book on ubuntu 11.10
Can't generate hello world pdf if type is Book on ubuntu 11.10
Status: CLOSED DUPLICATE of bug 756864
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ruediger Landmann
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-31 09:06 EDT by reda
Modified: 2011-11-28 21:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 21:21:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description reda 2011-10-31 09:06:13 EDT
Description of problem:
Publican can't generate pdf if type is Book

Version-Release number of selected component (if applicable):
publican 2.5 on Ubuntu 11.10

Steps to Reproduce:

$ publican create --type Book --name MyBook
$ cd MyBook
$ publican build --langs en-US --formats pdf  

Actual results:

But no pdf generated even if it says : 
Beginning work on en-US
	Starting pdf
	Using XML::LibXSLT on /usr/share/publican/xsl/pdf.xsl
Making portrait pages on A4 paper (210mmx297mm)
log4j:WARN No appenders could be found for logger (org.apache.fop.util.ContentHandlerFactoryRegistry).
log4j:WARN Please initialize the log4j system properly.
	Finished pdf
Comment 1 Henning Kockerbeck 2011-11-08 07:10:50 EST
I can confirm the problem, working with publican 2.5-2 on Ubuntu 11.10. The cause seems to be with the 'create' step, because projects I created before the upgrade from Ubuntu 11.04 to 11.10 continue to build just fine.
Comment 2 Henning Kockerbeck 2011-11-08 08:02:52 EST
Addendum: The problem seems to be with the corpauthor tag in the automatically generated file Book_Info.xml and the svg image that is referenced in it. I did some experiments:

- Remove the corpauthor tag in Book_Info.xml completely, including the tags inlinemedia, imageobject and imagedata inside of it: The pdf gets build fine.

- Remove the content of the corpauthor tag completely, but preserve the tag itself (e. g., "<corpauthor> </corpauthor>"): No pdf is generated, even though publican says that it did.

- Remove the content of the corpauthor tag and insert some dummy content (e. g., "<corpauthor>This is a test</corpauthor>"): The pdf gets build fine.

- Copy title_logo.svg over from an older project that continues to build fine (but which doesn't reference the svg image): No pdf is generated, even though publican says that it did.

- Throw together some little random svg image in Inkscape and reference it in the imagedata tag: No pdf is generated, even though publican says that it did.

- Remove the corpauthor tag completely from Book_Info.xml and insert the inlinemediaobject tag with the said random svg image somewhere else, e. g. in Chapter.xml: The pdf gets build fine.

- Keep the corpauthor tag removed and insert the said random svg image into the para tag that is inside the abstract tag: The pdf gets build fine.

- Let the imagedata tag inside the corpauthor tag reference some other, non-svg image, e. g. important.png: No pdf is generated, even though publican says that it did.

So I think there is a problem with images inside the corpauthor tag in Book_Info.xml. If you remove that corpauthor tag or at least use no images in it, you should be fine until this problem gets fixed.
Comment 3 Jeff Fearn 2011-11-08 16:44:59 EST
Hi, this looks like an issue with FOP. FOP is always giving us a lot of problems, on every single platform, so it's hardly surprising Ubuntu finally got bit :(

It looks like FOP wants to complain about something in there but log4j isn't configured, or a component has been deprecated, or maybe moved to a different package that isn't being pulled in by default.

Assigning to Rudi who knows a more about FOP and Ubuntu than I do.

Cheers, Jeff.
Comment 4 Jeff Fearn 2011-11-28 21:21:15 EST
corpauthor tag has been fixed for 2.9 BZ #756864 and that seems to have fixed this issue as well.

FYI FOP being caught when dieing was fixed in 2.6 for BZ #661551

*** This bug has been marked as a duplicate of bug 756864 ***

Note You need to log in before you can comment on or make changes to this bug.