Bug 75031 - Upgrading from 7.3, German console keyboard with wrong characters
Upgrading from 7.3, German console keyboard with wrong characters
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 16:47 EDT by Sven Hummel
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 16:05:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File i18n which currently works. (68 bytes, text/plain)
2003-02-03 06:58 EST, Sven Hummel
no flags Details

  None (edit)
Description Sven Hummel 2002-10-03 16:47:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; DT)

Description of problem:
After upgrading from 7.3 the german console keyboard layout is wrong.
Changes thrue kbdconfig will result in no changes from
"de-latin1-nodeadkeys" to "de-latin1" and some changes by "de"
wich are also wrong but different.

The keyboardlayout under X works well !

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 7.3 fresh with german language and german keyboard
  "de-latin1-nodeadkeys".
2.Upgrade with 8.0 again german language and german keyboard
  "de-latin1-nodeadkeys" (doesn4t matter if text or grafik
   installation)
3.Login as root

Actual Results:  Under layout "de"
Pressing key "A with diaeresis" get assigned as "}"
Pressing key "O with diaeresis" get assigned as "{"
Pressing key "U with diaeresis" get assigned as "\"
and so on with the keys from latin1 charset. 

Under layout "de-latin1" and "de-latin1-nodeadkeys"
Pressing key "A-Umlaut" get assigned as "-"
Pressing key "O-Umlaut" get assigned as "O^"
and so on with the keys from latin1 charset.

Expected Results:  Get the sign as required.

Additional info:

Under this circumstances files are created,
modified or changed with wrong characters.
It can result in crashes or lost of data with
server buisness applications.
Comment 1 Sven Hummel 2002-10-06 06:04:04 EDT
After two upgrades on two different systems with the same result
i have tried to find a solution untill i get info from you.

I feal the problem is in the consolefont.

Trying "/lib/kbd/consolefonts/iso01.16.gz" for the consolefont works.

Searching more for the "Why wrong after upgradig ?" have bring me
to this result.

The file "/etc/sysconfig/i18n" is different depending what type of installation.

Upgraded system from 7.2-->7.3 have only one line "LANG=....." inside this file.

Fresh installed system 7.3 have the following lines inside (german version!)

LANG="de_DE@euro"
SUPPORTED="de_DE@euro:de_DE:de"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

There are two possible reason4s why it have been working befor the upgrade,
wich i can not figure out:

1) The file i18n is not fully used in versions befor 8.0.

                       or

2) The file "lat0-sun16" is corrupted.

Hope this helps to find a solution.
Comment 2 Sven Hummel 2003-02-03 06:58:30 EST
Created attachment 89801 [details]
File i18n which currently works.

I have come to know that the bug is known already by RedHat from
an engineer.

I have include my currently working settings.

I´am wondering how long it takes until somebody takes care about
this problem as it is a basic problem also for other countries
like spain anso.
Comment 3 Eido Inoue 2003-02-19 16:05:36 EST
the kbd description labels keep changing release-to-release... esp after the big
euro and latin1->latin9 switchover. As a feature for a future release, this
issue (standardized descriptors for both console and X keyboard settings) needs
to be addressed for the sake of compatibility and upgrades.

Note You need to log in before you can comment on or make changes to this bug.