Bug 75050 - long delay opening window from home icon
long delay opening window from home icon
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 19:52 EDT by tom georgoulias
Modified: 2015-01-07 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-20 18:31:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (202.53 KB, text/plain)
2002-10-03 19:54 EDT, tom georgoulias
no flags Details
strace of nautilus freeze/crash behavior for #75050 (286.61 KB, text/plain)
2002-10-08 21:28 EDT, tom georgoulias
no flags Details
strace -tf gedit (23.36 KB, text/plain)
2002-10-18 19:31 EDT, tom georgoulias
no flags Details

  None (edit)
Description tom georgoulias 2002-10-03 19:52:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The first time I double click the home icon on my desktop, nautilus will pause
for a long time, appear to crash, then open a file manager window.  While this
is happening, the icon is shaded and I am able to launch new applications from
the panel.  I am not able to start anything new using the workspace menu panel
(right mouse button).  This seems to occur only after I manually start ppp from
a terminal window (ifup ppp0).  I often have mozilla and/or evolution running at
the same time.  I was successful in capturing this behavior in an strace and the
output file is attached.  

BTW, I'm not completely sure that ppp has anything to do with it, but since it's
normally the first in a series of things (terminal, dial up, evolution,
mozilla...) I start everytime I log in I figured I'd mention it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in.
2. manually start ppp from terminal with ifup ppp0
3. start evolution and/or mozilla
4. double click home icon on desktop.
	

Actual Results:  Nautilus will "freeze", no window will open for a long time,
and the application appears to crash and respawn.

Expected Results:  File manager window should open, with the contents of my home
directory.

Additional info:

[tomg@gemini tomg]$ rpm -q nautilus
nautilus-2.0.6-6
Comment 1 tom georgoulias 2002-10-03 19:54:41 EDT
Created attachment 78484 [details]
strace output
Comment 2 tom georgoulias 2002-10-08 21:28:03 EDT
Created attachment 79546 [details]
strace of nautilus freeze/crash behavior for #75050
Comment 3 tom georgoulias 2002-10-08 21:34:58 EDT
I've attached a second strace of this problem, after having deleted the
following directories: .gnome*, .metacity/sessions/*, .gconf*, .nautilus and
letting the system recreate them.  I also formatted my disk and a did a fresh
install of 8.0 (I had previously gone from null to 8.0 by upgrading, not
reinstalling), just to be sure there wasn't any leftover stuff screwing me up. 
My /home was preserved when I installed 8.0, so I figured deleting the
directories mentioned above would do a decent job of wiping the slate clean. 
Other curious behavior I've noticed:  when nautilus takes a dive like this, I
cannot open gedit from the gnome menu nor from a terminal.
Comment 4 tom georgoulias 2002-10-16 18:20:55 EDT
I've confirmed that Nautilus only crashes/freezes/respawns like this when the
modem is up and running.  Nothing unusual happens until I dial in to my ISP, and
all problems go away after I disconnect and Nautilus respawns.

I'm guessing this bug is ultra-low priority simply because it hasn't been
scheduled yet, but if you have any fix suggestions or want more system info I'd
be glad to provide it.
Comment 5 Havoc Pennington 2002-10-17 16:51:28 EDT
nautilus is probably getting confused about some aspect of 
your network configuration; maybe reverse DNS lookup 
stops working, or the like. If you try connecting to the internet 
_before_ logging in, does gnome complain in a dialog as it starts up?
Comment 6 tom georgoulias 2002-10-18 00:11:41 EDT
Gnome doesn't even start up enough to display a dialog.  I connected my ISP in
run level 3, then used "startx" to start my gnome session.  The splash screen
image is displayed on a black background (instead of blue) and none of the icons
that appear as services are started ever showed up--everything just hung.  I
waited about 2 minutes for something to happen and nothing did, then switched to
another virtual terminal and disconnected the modem.  The splash image stayed
"frozen" for an additional 2-3 mins, then the blue background appeared and the
service icons started.  Once the gnome session was fully up, I still didn't see
any dialog at all about network problems.

I'm still confused about my inability to launch gedit from the gnome menu too. 
That happens as well (even now--just tried to open gedit while connected and
commenting on this bug report via mozilla and gedit won't display.  Disconnected
and gedit showed up about 1 minute later.)
Comment 7 Havoc Pennington 2002-10-18 02:16:47 EDT
I'm having trouble seeing where the hang is in the strace. 
Maybe strace with the "-t" option? Ideally one of the simpler apps 
instead of nautilus, something as simple as "gsearchtool" for example, 
if it hangs.
Comment 8 tom georgoulias 2002-10-18 19:30:04 EDT
OK, I've created a new strace with gedit.  Here's what I did:

1. Connected to my ISP with the modem.
2. strace -o /tmp/strace_gedit.out.tf -tf gedit
3. Disconnected the modem, then waited for gedit to start.
4. ^C after gedit was up and running.
Comment 9 tom georgoulias 2002-10-18 19:31:21 EDT
Created attachment 81045 [details]
strace -tf gedit
Comment 10 Havoc Pennington 2002-10-20 12:42:57 EDT
Looks like some kind of problem with the networking setup, see appended 
strace portion. Does "ping $(hostname)" work? "ping localhost"? 
"ping 127.0.0.1"?

1081  18:25:58 bind(16, {sin_family=AF_INET, sin_port=htons(833),
sin_addr=inet_addr("0.0.0.0")}}, 16) = -1 EACCES (Permission denied)
1081  18:25:58 connect(16, {sin_family=AF_INET, sin_port=htons(111),
sin_addr=inet_addr("127.0.0.1")}}, 16) = -1 EINVAL (Invalid argument)
1081  18:29:07 close(16)                = 0
1081  18:29:07 fstat64(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
1081  18:29:07 mmap2(NULL, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x4001b000
1081  18:29:07 write(1, "FAMOpen failed, FAMErrno=0\n", 27) = 27
Comment 11 Havoc Pennington 2002-10-20 12:43:20 EDT
(try the pings while net connection is active clearly)
Comment 12 tom georgoulias 2002-10-20 18:29:44 EDT
Got it resolved.  The network service daemon wasn't running because files from
the initscripts RPM were corrupted.  Reinstalled the initscripts RPM, verified
integrity of the RPM, and restarted the network service.  Everything is running
smoothly now.
Comment 13 tom georgoulias 2002-10-20 18:31:49 EDT
BTW, none of the pings worked before I reinstalled the RPM, but I'm sure that
doesn't really matter now since file corruption was the culprit.
Comment 14 Alexander Larsson 2002-10-21 04:59:45 EDT
closing...

Note You need to log in before you can comment on or make changes to this bug.