Bug 750506 - /etc/filesystems does not contain 'ext4'
/etc/filesystems does not contain 'ext4'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
: 769962 (view as bug list)
Depends On:
Blocks: 771388
  Show dependency treegraph
 
Reported: 2011-11-01 08:10 EDT by Daniel Berrange
Modified: 2012-01-30 16:00 EST (History)
3 users (show)

See Also:
Fixed In Version: setup-2.8.33-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 771388 (view as bug list)
Environment:
Last Closed: 2012-01-07 18:05:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2011-11-01 08:10:01 EDT
Description of problem:

The mount command may use /etc/filesystems for mounting filesystems with type 'auto':

 [quote mount(8)]
              If  no  -t option is given, or if the auto type
              is specified,  mount  will  try  to  guess  the
              desired  type.   Mount  uses  the blkid or vol‐
              ume_id  library  for  guessing  the  filesystem
              type;  if  that  does not turn up anything that
              looks familiar, mount will try to read the file
              /etc/filesystems,  or,  if that does not exist,
              /proc/filesystems.  All of the filesystem types
              listed  there  will  be tried, except for those
              that are labeled "nodev"  (e.g.,  devpts,  proc
              and  nfs).   If /etc/filesystems ends in a line
              with  a  single  *  only,   mount   will   read
              /proc/filesystems afterwards.
 [/quote]

The setup RPM creates an /etc/filesystems which only contains

  # cat /etc/filesystems 
  ext3
  ext2
  nodev proc
  nodev devpts
  iso9660
  vfat
  hfs
  hfsplus


Since /etc/filesystems exists, and does not contain '*', /proc/filesystems will never be used.

Ordinarily libblkid would detect the filesystem type, so /etc/filesystems will not be consulted, but if it is consulted, it'll miss many modern filesystems, in particular 'ext4', but also 'brtfs'

Since ext4 is the default Fedora filesystem, it should really be included in /etc/filesystems. Alternatively appending a '*' would let it fallback to using /proc/filesystems.

Version-Release number of selected component (if applicable):
setup-2.8.31-2.fc15.noarch

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Vasik 2011-11-02 09:26:01 EDT
Thanks for the report, fixed in rawhide(ext4 added), setup-2.8.42-1.fc17 ... do you want the update in f15 or rawhide fix is enough?
Comment 2 Daniel Berrange 2011-11-02 09:34:33 EDT
rawhide is sufficient for me
Comment 3 Ondrej Vasik 2011-11-02 09:46:49 EDT
Ok, thanks for quick reply, closing RAWHIDE.
Comment 4 Ondrej Vasik 2011-12-23 05:06:46 EST
*** Bug 769962 has been marked as a duplicate of this bug. ***
Comment 5 Ondrej Vasik 2011-12-23 05:14:37 EST
Reopening, will fix that in F15/F16 as well.
Comment 6 Fedora Update System 2012-01-03 07:09:46 EST
setup-2.8.36-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/setup-2.8.36-3.fc16
Comment 7 Fedora Update System 2012-01-03 07:11:01 EST
setup-2.8.33-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/setup-2.8.33-2.fc15
Comment 8 Karl Grindley 2012-01-03 10:09:59 EST
also broken in RHEL6
Comment 9 Fedora Update System 2012-01-03 20:58:47 EST
Package setup-2.8.36-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing setup-2.8.36-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0085/setup-2.8.36-3.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-01-07 18:05:54 EST
setup-2.8.36-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-01-30 16:00:50 EST
setup-2.8.33-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.