Bug 75051 - snmptable causes segment fault
snmptable causes segment fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: net-snmp (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 19:55 EDT by Need Real Name
Modified: 2015-03-04 20:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 08:32:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-03 19:55:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When usig snmptable command to get table infomation for MIB-II by SNMPv2c or 
SNMPv3, it causes segment fault

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add a communnity "test" in /etc/snmpd/snmpd.conf, add line "rwcommunity test"
2.restart snmpd
3.run snmptable -v 2c localhost test at.atTable

	

Actual Results:  segment fault

Expected Results:  get infomation about the table.

Additional info:

In net-snmp 2.2.3, it's ok, Problem appears in net-snmp 2.2.4 and 2.2.5
Comment 1 Phil Knirsch 2003-01-14 08:32:17 EST
Works for me in 8.0 and later.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.