Bug 75051 - snmptable causes segment fault
Summary: snmptable causes segment fault
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-snmp   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-03 23:55 UTC by Need Real Name
Modified: 2015-03-05 01:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 13:32:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-03 23:55:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When usig snmptable command to get table infomation for MIB-II by SNMPv2c or 
SNMPv3, it causes segment fault

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add a communnity "test" in /etc/snmpd/snmpd.conf, add line "rwcommunity test"
2.restart snmpd
3.run snmptable -v 2c localhost test at.atTable

	

Actual Results:  segment fault

Expected Results:  get infomation about the table.

Additional info:

In net-snmp 2.2.3, it's ok, Problem appears in net-snmp 2.2.4 and 2.2.5

Comment 1 Phil Knirsch 2003-01-14 13:32:17 UTC
Works for me in 8.0 and later.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.