Bug 750673 - Admin should be able to mark project as obsolete and hide from view.
Admin should be able to mark project as obsolete and hide from view.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Maintainability (Show other bugs)
1.5-SNAPSHOT
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
: 756923 (view as bug list)
Depends On:
Blocks: 756230
  Show dependency treegraph
 
Reported: 2011-11-01 20:43 EDT by Alex Eng
Modified: 2012-04-23 00:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.5-SNAPSHOT (20120208-1817)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 00:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Eng 2011-11-01 20:43:12 EDT
Description of problem:

Admin should be able to mark project as obsolete and hide from view.

This should apply at 2 level - 
 - The whole project regardless of the version
 - Specific project version.
Comment 1 Alex Eng 2011-11-21 16:50:57 EST
Restriction applies on obsolete project/project iteration: 
Translation
REST access
Translation Memory

See https://github.com/zanata/zanata/commit/efac31a3e24684241c74126fd95e5b5f5191ecdb
Comment 2 Carlos Munoz 2012-01-18 19:01:19 EST
Added REST API restrictions as well as a status field on projects and iterations. They appear on Project/Iteration GET resources. Since obsolete projects are not visible anyway, the only current values that will be seen are 'Current' and 'Retired'.

See
https://github.com/zanata/zanata/commit/4d57eb79ac88f6e720a83fd77bb793ace7380293
https://github.com/zanata/zanata/commit/b7976ce5d0aa81fb089feabdf74fe7a4e5a82815
Comment 3 Carlos Munoz 2012-01-31 21:08:56 EST
Corrected wrong status on Project when fetching from the REST API.

See
https://github.com/zanata/zanata/commit/6c9f9010a817baf0e6b27f4212d89a81b3bebecf
Comment 4 Ding-Yi Chen 2012-02-06 02:01:10 EST
For Maven client, ADMIN can still push to a retired project. 

client API version is 1.4.6-SNAPSHOT, but server API version is 1.5-SNAPSHOT
Comment 5 Sean Flanigan 2012-02-06 03:02:25 EST
As I said in https://bugzilla.redhat.com/show_bug.cgi?id=755759#c2 for read-only projects, we should enforce in REST API, and also at the Entity level if feasible.

In this case, I think we need we're missing some restrictions in TranslationResourcesService.
Comment 6 Sean Flanigan 2012-02-07 02:58:53 EST
Please retest with https://github.com/zanata/zanata/commit/3096605f4d2c42db112d157b6ceb917fec562f67 (master branch)
Comment 7 Ding-Yi Chen 2012-02-08 09:14:42 EST
VERIFIED with Zanata version 1.5-SNAPSHOT (20120208-1817)
Comment 8 Sean Flanigan 2012-04-23 00:26:01 EDT
*** Bug 756923 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.